Synology SPK-Package: Development

@bplexico - I do not have a lot of other packages running on this device and I have 16G of ram, so that should not be an issue.

Regarding playback issue - playing a standard redbook - there will be dropouts during the music, so playing fine, a 1 second’ish drop, and then back to playing. Rinse and repeat. Different tracks, etc. Run the same software on my Windows 10 box and/or Mac box against the same files - no problem. Same cable, same external DAC connected directly to the NAS. I am thinking it has something to do with the audio USB driver. I have stopped most other services to run with a bare minimum - no impact.


@Nick_Shanny - Yes it does sound like it may be a problem with the USB audio driver. I would assume trying a different USB port on the NAS does not make a difference?


1 Like


I just wanted to say ‘thank you’ to Christopher Rieke for the SPK.

It is working reliably on my Synology DS415+ (with 8GB memory upgrade) and it is taking some of the processor workload off my pc when up-sampling tracks using HQ Player. Consequently I am able to up-sample reliably to DSD512 for the first time. It also increases flexibility, allowing me to access different Roon endpoints directly from the NAS when the pc is switched off.

It has been a very worthwhile software change for me. Thank you.


1 Like

Thanks, running on a Synology DS916+ 8Gb. Great work!!

1 Like

I have a DS415play and when I try to install any of the packages it comes up with a message saying “This package is not supported on the platform of DiskStation”. Does it only work for ‘+’ models?

Roon Server is only available for 64Bit Intel CPUs. Unfortunately the DS415play has a 32bit CPU and can’t run it.

I’ve been looking forward to trying this on my DS1813+, and finally got around to isntalling. It looks very promising! But I don’t seem to be having any success getting anything to play. The package installs fine, and it imports my library, and recognizes all the endpoints on my network, but when I try to play, it get errors, either “Tidal: A networking or connectivity problem is interfering with TIDAL playback” or “Roon: An audio file is loading slowly. This may indicate a performance or hardware problem”. Endpoints include an Auralic Aries, a couple of Cubox’s and my computer. The problems occur after the entire library loads, and I turned off the Audio Analysis to minimize processor load, so I think something else is getting in the way of playback. I’m wondering if other services my be using the same network resources? Minimserver and Logitech Music Server (LMS) are also installed, but stopped. Am I missing anything regarding file access privileges? I’m really keen to get this working, so any help is appreciated. Cheers.

Can you check if this issue also occurs if you connect a DAC directly to your synology?
It is very often network related. Do you have any special setup (switch, jumbo frames, etc…)?

1 Like

I connected my info nano to the disk station, but the nas doesn’t seem to recognise it. All els worked well when I ran the core on my desktop, so most of the network equipment should be fine. The only thing unusual might be the 4 network ports on the nas are configured as a team.
I’ll dig around more a bit later to see what I can deduce about the USB and DAC and come back here with any conclusions. If any other ideas for things to check come to mind, let me know and I’ll report back.

Hi Cristopher,
Still no luck making things work. My DAC is plugged into a USB3 port, and is recognized in the DSM control panel as a USB Audio Device, but Roon doesn’t recognize any devices connected directly to the core, so something else must be awry on my system. I left it running the background audio analysis, which should finish up later today. I doubt everything will snap into shape when that’s done, but I can’t think of anything else that may be causing the problem.

Can you test if you can use the DAC with Synology’s AudioStation?
Try to play something there. If it works, you can stop the playback and stop and start the Roon Server package again.
See if your DAC will be seen by Roon Server afterwards.
This worked for someone else to make the DAC visible in Roon Server…

Okay, progress! AudioStation wasn’t installed, so after installing it, Roon Server sees the DAC and is playing music through it (I didn’t even have to play anything on AudioStation - it was running after install, which seemed to resolve the problem). I hoped that might also fix the playback through the other devices, but no luck.
I’ll try a few things to get things straightened out - restart, remove the teamed networking and anything else that comes to mind. I’ll welcome ideas from anyone who has suggestions.

Update 1: AudioStation needs to be installed to use a local DAC, but it doesn’t need to be running.

Success! I had jumbo frames enabled in Network Settings on the Diskstation. Disabling that got things working everywhere now :slight_smile: And, I never would have thought to plug my DAC into the Diskstation, so that saves me one more device in my home automation closet, and I can use the Cubox I had in there for something else. I need to have AudioStation installed, but it doesn’t have to be running for Roon to use the LocalDAC.

This could be a super multi-room system: plug in two or three DACs to a Synology NAS to feed an audio distribution system, and use the network to feed a streamer in the audiophile zone and you’re all set!

This is so cool! :grinning:

1 Like

Can you also check if the DAC still works with Roon Server when you uninstall AudioStation again or if it needs to be installed?

I tried uninstalling Audiostation and my Audiophillio USB to SPDIF converter disappears again, so it definitely looks like Audiostation is required.

Ok. Thanks BE718. Then I’ll take a look what else is inside the AudioStation package, that might be required by Roon…

it looks now that roon uploaded 32-bit server versions? will your package work for play models now?

I just checked the download section and 32bit versions are currently only available for Windows systems. Not for Linux.
If I am missing something, please send me the URL. :slight_smile:

yes, you are right here !

Anyone tried to compare performance of Roon Server on Synology from HDD (e.g. RAID array) to Roon Server from SDD / external USB3-SDD / eSata-SDD? I’d really like to know before investing in this. Especially searches in Roon are a lot slower on my 1815+ HDD (RAID) install of Roon Server right now compared to a stand-alone reasonably recent PC with SSD. But, I’d like to stay with the Synology NAS install if performance can be improved with an added SSD.