System froze; after reboot, Roon/macOS no longer thought it was a core

Core Machine (Operating system/System info/Roon build number)

10.15.7, Roon 1.7 build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Hey all, I’ve worked around this issue but I figured that the least I could do is report it in case my experience helps identify a problem. My 10.15.7 system froze (for the first time in months) and when I rebooted, Roon showed a login prompt. Normally my Roon credentials are saved. After logging in with my Roon creds, Roon asked whether I wanted to find cores on my network or make that machine a core. Alas, Roon had been a core on this machine for 2+ years right up to the system freeze.

After realizing that Roon no longer thought it was a core, I restored a previous backup, logged back in to Roon, de-authorized the previous instance of this machine (since my Roon account only allows 1 core and it thought this same-named machine was new), and everything’s working normally now.

When I rebooted, neither the OS nor Roon said anything about filesystem corruption (nor the status of or path to its library data). All other apps started normally. Roon was running at the time of the system freeze, but I wasn’t playing music or using it interactively.

The only noteworthy thing is that I upgraded from 10.15.6 to 10.15.7 about 36 hours prior. Roon successfully restarted and acted as a core in the reboot immediately after that upgrade, though. It makes me wonder whether something about Roon’s default path for the library may be based on a path from the OS and the defaults may have changed in 10.15.7. That’s just a very long-shot guess, though.

Restoring the backup and recreating my settings worked around the problem for me, but I figured I’d pass this on. Hope this helps.

1 Like

Hi @t812,

Thanks for reaching out and for letting us know your experience here! It does sound like the OS update happening immediately before the issue may have triggered the strange behavior, but if you notice any other issues, please just let us know and we can take another look, thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.