System not working after update

Core Machine (Operating system/System info/Roon build number)

Mac OS Catalina 10.15.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet DSL

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos wifi

Description Of Issue

since the update my core is not recognized

Hi @Allen_Shah

Since experiencing this issue have you tried rebooting the Core?

What do you see when you try to launch Roon? Can you share a screenshot?

Hi Dylan, thanks for the response; here is the screen shot of what I see; hope you can see it.
Basically just says “searching for roon core” and never stops searching.

So I rebooted the computer and router without success with this problem, but I admit I am not sure how to reboot the core itself as opposed to rebooting the computer. My core is the app on my Mac and I cant get to any screen other than the one I showed you in the screen shot; so cant get to any settings menu.
How might I reboot the core itself?


A post was split to a new topic: Trouble getting Roon to work properly

I think you are labouring under a misapprehension here.

You have installed Roon on a Mac. Your Roon Core is part of that. Roon (and its Core) are running on Mac OS.

What you have done is gone into Settings > Setup and clicked the " Configure" button for a Core running on Roon OS.

Roon OS is the operating system used by the Nucleus products and NUCs built using ROCK.

Since you don’t have these in your network, Roon can’t find them and will keep looking until you leave this screen.

Just ignore this Configure button. It is irrelevant in your setup.

Hi @Allen_Shah

As Geoff mentioned, the Configure Roon OS Core option is specifically for configuring Nucleus / ROCK devices and shouldn’t be necessary here.

In this screenshot are you using the Core machine directly, or are you on a different device trying to connect to the Core machine?

If you hit Done to close the configure Roon OS page what do you see?

Hi Guys, and thanks for the help; so I am using the mac desktop that I originally downloaded roon onto, so this is the core I am using and giving screen shots of. I actually did not try to get to any settings menu or reconfigure anything.
At the bottom of my home screen on my mac is the roon icon; and previously I would just press the icon and roon would open, with all the music choices and so forth.
But since the update when I open roon, this is the screen I see:

At the bottom is the option of “configure roon, etc” and I will not do anything with that (thank you Geoff)
The next option is to ‘find roon core’ and when I press that it continues to cycle and does not find anything.
That leaves the third option, ‘use this mac’ and when I press that it sends me to a log in screen, and if I log in I get this screen,

So this says I’m signed into a core already, but here on my core I’m unable to get to any screen that shows any music I have.
Previously I never used any other control of my roon content other than using this icon on my computer, so I’m not sure where else to go.
And I do not have any other core than what is on this desktop computer.


Just click the Unauthorize button, and you should be up and running. In rare cases, the Update process seems to go awry, and you end up in this corner…

Thanks so much- that worked!!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.