Tagging and importing tracks problem

Setup: ROON latest version on Windows 11 computer, intel i7 chip. Installation was quick and easy. Music is stored on a NAS with a mapped network folder on the computer. I am testing the setup on system speakers (cheap 2-way speakers RCA connected to the computer).
I am completely new to ROON but I’ve been using other software packages (MP3Tag, VLC, Winamp, Audacious, Musicbee) for quite some time > 5 years.
If the exact same question has been asked before, please be gentle with me and link to the correct thread. I have been reading and searching on the net however but did not find an answer to these questions.
I am a 43 year old music enthusiast and I am in the process of buying a new pre-amp/poweramp combo, I already have the speakers, B&W 802D3. I only listen to internet radio and my own library that consists of approximately 8000 tracks, the vast majority of that is FLAC. Together with that pre-amp/poweramp combo comes the decision for the streaming software. Right now, I am in my 14 day trial period of ROON (with still 10 days left) and I have been playing around with it for quite some time now. Apart from some great features and possibilities that ROON offers, I also have two major issues with the software:
Let me first tell you that for testing purposes, I made a folder that contains only two albums, one is the Greatest Hits album from The Bangles and the other is a compilation album from various artists containing mostly rock and softrock tracks. All the tracks are tagged for their original album, so few songs on the album from The Bangles are originally released on that Greatest Hits album but others were released on other albums (Different Light, Everything, …), all files are tagged accordingly with album name, release date and cover art. The same for the compilation album.

  1. ROON does not recognize the original album tagging, instead they tag every song on the album from The Bangles as coming from Different Light but with cover art from their Greatest Hits album. Every other software package I use, does recognize the correct tagging (MP3Tag, VLC, Musicbee, Blusound, …)
  2. The compilation album from various artists does not even load in ROON, none of the tracks. All the files are named the same way:
    01 – Artist – Songname.flac
    Including the album from The Bangles, all are named in the exact same manner. The Bangles album loads just fine, the other album not, I also checked the “skipped files list”, no skipped files, these tracks simply don’t exist according to ROON. Again, every other software package I use, recognizes (and plays) the files just fine.
    Files and screenshots can be provided on request.
    Is there someone who can help me with these issues? Thanks in advance.

In the Roon settings have you set the option to prefer your file tags over Roon database upon importing files?

Yes, I did

Small update here. All of my albums are organized in different folders (who does not?) with the folder name being [release year] Artist - Album Name. If I remove the folder names and just put all of my files in one folder, everything is imported like it should, no more tracks missing, album name, release year, cover art, … are all there. Is there a way to let ROON know it should not retrieve any data from folder name, just from tags?

odd. All my files are in the following folders:

Artist\Album Name\track number - track name

I wonder if the folders starting with [release year] is the problem. Try some folders named just “Artist - Album Name” and see what that does. Using tags, the actual file names and folder locations should be irrelevant.

OK, were are slowly getting there. Thanks for the help so far garym.
Organizing the folders the way you described did the trick Artist\Album\track number - track name. But only if I set all the import settings to “prefer Roon”, at that point all files were imported, no skipped files and all cover art and album names … were correct. The only minor thing I have now is that The Bangles are sometimes called “The Bangles” and sometimes “Bangles”, Any solution for that?

You can edit Roon information once the files are imported. But I still think there is something wrong. Roon should be able to import using your tag info. It works for me with about 120,000 tracks. I’m out of ideas, but paging @support

Small update here again but not so good one. So I’ve been changing my folder names to the above structure and still some folders failed to load. If I select this folder specifically, no tracks are imported, no skipped files. Tried clearing cache, no improvement. Desperately calling out to more support. What am I doing wrong? There are no special characters in the track name or folder names. All other software packages loads these files just fine, they are normal flac files. HELP!

@Ivan_Sannen I sometimes had problems with too long file names, special characters and wild arrangement. I have fixed all that with this scheme.

$cut(%album artist%,50)/$cut(%album%,80) [’[’%date%’]’ ]%H%/$num(%discnumber%,2)%tracknumber%. [$cut(%artist%,50) - ]$cut(%title%,50)

The album artist is cut after 50 characters then there is a new sublevel with / for the albums 80 characters and release date in square brackets in case it is ever unknown. Then another letter that distinguishes versions.

After a / the file level is described with disc number and track number followed by a dot. The track artist and title are also shortened to 50 characters with a hyphen.

Thanks for your reply. In the folder “Metallica” the albums “And Justice for all” “Master of Puppets” and Death Magnetic" load just fine, the album “Metallica” fails to load. If I rename that folder to “Black Album” no change. If I put all the files from that folder under the root folder, bang, they all appear in ROON. Is that folder name too long? Special characters? I truly appreciate your help but I think something else is happening and for the moment I don’t know what exactly. Is there a way to make a ticket for factory support?

Maybe the program just wants to prevent a mistake from happening, because it doesn’t believe that artist and album are named the same. If this change is made with Black Album Metallica in the metadata, what happens?

The team is currently busy because of other problems and grateful if the community first exchanged ideas and if no one has more ideas, I would send it to the team with the latest findings. Maybe someone is already reading along and see if we can get ahead that way.

I have numerous albums with same title as band name, and Roon handles them just fine. Something odd is wrong here.

Renaming and retagging to “Black Album” doesn’t make any changes. i agree with garym, Prince/Prince; Queen/Queen; Feargal Sharkey/Feargal Sharkey and ABBA/ABBA all load just fine, only Metallica gives problems. There something with that folder I am overlooking and I (or we) need to find out what.

Serious question: could all this hassle be caused by using mapped network folders? More or less by accident I loaded some files from my local disc (C:) and all files loaded without any problems, this was an old playlist still on my local drive. Thinking I havn’t tried that option, I copied a large part of my library to my local drive, left it running overnight and selected the drive this morning in ROON. All files loaded, not one missed.

If everything is tagged the same and only another (NAS) drive, another folder is used, it is very likely that a global share is affected by many small “locked” (copy)(move) actions. This then has nothing to do with Roon (or does it) if such actions are done only with Roon.

Not exactly sure what you mean here, I am a real tech-fool. For now I can only determine that working from a mapped network folder gives problems, from a local folder not. I’ve been playing around with ROON more this weekend and all files are loaded from the local folder, not one skipped. Calling out to @garym here, you have 120 000 tracks, substantially more than me and don’t seem to have any problems. Were are they stored?

You might try pointing Roon directly to your NAS instead of the OS mapped drive. I don’t see why it should make a difference, but…

Stored on 4TB USB drive directly connected to my NUC that is running ROCK operating system.

Pointing directly to the NAS didn’t make any difference. I still think ROON OS running on a different machine compared to the library is the key here. My NAS is more a home build running linux mint. I might try installing ROON on that machine but my 14 day trial is coming to an end (2 days left), not sure if I have time to check that out. Still, I learned a lot these past 12 days.

This topic was automatically closed after 18 hours. New replies are no longer allowed.