Tailscale implementation with ARC to circumnavigate ISP CGNAT

I really don’t understand your point. ROCK works with Tailscape on a synology (or other machine) functioning as a subnet router. That is what the video instructs you to do. By all means point out the need for it to function as a subnet router but why continue to insist it’s not a working option.

I missed that part of the message.

I thought it was about running Roon on a Synology using Tailscale. I already have Tailscale running on my Synology so I will watch the video and see, that actually might give me what I was trying to get too without replacing Rock.

Yes ARC is the game changer because it’s designed to cope with small outages and operates on an IP basis where Roon Remote connects to the core via UDP.

1 Like

Ok I just bookmarked it to try later.
This is much bigger improvement than I had thought when I read the article headline.

Arc already work’s great but through this method I can use ARC use it in the office on a limited access network through Tailscale from my ipad or iphone that do not have Sims in them :smiling_face_with_three_hearts:

(as the person who introduced the firewall limits I am not going to turn it off :crazy_face:)

Great, pleased it can work for you. Here’s another video for the thread showing how to set up a Tailscale subnet router, not specific to Synology.



Hi Andy, Do you run Tailscale on iOS or Android my previous impression was that on iOS the background use of the Tailscale App was quite significant, it may I guess have improved of late with app updates.

beginner’s question here … I find myself unable to go through with Step 3.2 here:

3. Connecting to Other Devices on your Local Network

  1. Run the command below, substituting your internal IP subnet where the is listed below. To be clear, you should only be changing the 192.168.1 portion so that you’re able to connect to all devices on your local network.

sudo tailscale up --advertise-routes --advertise-exit-node --reset

what is my internal IP subnet?

Would be great if this works!

They do explain this in the video but my understanding is you should look at the ip addresses on your home network, if for example the ip address of your roon machine is your internal subnet is

The reasoning is the first three numbers are the address ranges that your internal DHCP server is handing out, you replace the last number with 0/24 because that is specifying the range of host addresses that can be handed out on the subnet.

If for example your ip addresses were commonly, or your internal subnet is likely

They say in order to learn something your teacher must understand it, so I wish you luck because this is a subject I’m am only just learning!

I’m running it on iOS. I’ve not checked the background usage! I’m sure there will be an overhead though. I am running a 12 mini which would make a good hand heater in the winter if it’s doing any kind of processing. I will have to see if I get battery issues I guess.

1 Like

I’ve installed on my Synology NAS, all seems to be working OK.
Disabled quick connect.
For my Synology Apps on the iPhone I changes the quick connect IP and replaced with the Tailscale IP for the NAS.

I ran the SSH commands but didn’t get the ‘success’ return but can see the options in the Tailscale dashboard.
Overall access seems faster than quck connect.
Just need to look at direct access to my IP cameras but that’s not a great issue as I can access via the DS CAM app.

Oh and I deleted all my port forward rules.
Overall seems a good find and easy to setup following the guide, applying to Synology.

Pleased you got a good result too. Especially as it was you that unlocked the thing for me with that video!

I didn’t get the ‘success’ return for the SSH command either. Just in case anyone else makes the same mistake the SSH commands are not uppercase although they appear to be in the video subtitles. SSH commands are lowercase.

The connection does seem very fast running on 4g and 200/200mbs fibre at the home end.

I noticed that running on 4g ARC downgrades the output to lossy, directly on the home network I get full 96/24 from the files I have in that format.

So after installing Tailscale I removed my quick connect access as it seemed prudent to limit access.

If I can get ARC workings through Tailscale and also working when going through dead Zones while driving, then like you I will remove my port forwarding rules.

Just to confirm that on my home network I have an intel NUC running Ubuntu 22.04 now connected to Tailscale as a subnet router. Roon Arc is working on iOS via the Tailscale VPN to my local ROCK install provided I perform the initial sync from my LAN. I cannot perform the initial sync via Tailscale VPN - lets see how it performs over time. Thanks.

Great that you have ARC working. I’ve seen reports about the initial sync being required from the LAN. Are you referring to the one off initial sync with the Roon core which should only be required once or some kind of sync that needs to happen more regularly?

I’m not sure how it would improve dead zones but there must be some buffering to allow for tunnels etc. on ARC. It doesn’t seem to have options for that like Plexamp does.

Just the initial setup sync via LAN, not sure what will happen when I add music to the core, not tried that yet.

Andy sorry that’s not what I meant.

Arc has improved dramatically in Dead zones through the beta and now works as well as PlexAmp in my testing.

What I meant was that VPNs tend to drop the connection when they go out of range so how seemless this works while driving will be part of the decision for some people as to whether or not they use it (if they already have a working ARC)

I plan to try it out this weekend and see how it goes.

Thanks a lot for explaining, Andy, … this worked so far. Now I completed step 6:

“After you enable both options, you’ll be able to connect to devices on your local network by their local IP address. At this point, you should be able to connect to DSM using the local IP address that you normally use at home.”

Do I need to do anything else? My Roon Core is on a NUC in the same network, do I need to indicate the Roon core IP somewhere?

No, you shouldn’t have to tell ARC your core’s IP address. It should be able to find it by itself. Though like others, I had the hiccup where I had to do the initial setup in the ARC app connected to my home wifi. But after that, all you should have to do is turn on Tailscale when you’re away from home (or with wifi disabled for testing) and ARC should automatically find and be able to access your core. I have occasionally had hiccups where ARC couldn’t find my core, but forcing ARC closed and reopening fixes it for me.

Your Roon core and Tailscale don’t have to be installed on the same device. My core is installed in a Docker container on a Synology NAS and Tailscale running as a subnet router is on a Raspberry Pi 4. As long as the subnet router is setup properly, when you connect to Tailscale away from home you should be able to access all the devices on your home network as if you were connected directly to it. ARC should be able to auto-discover your core.

As a bonus, in fact with a properly setup subnet router, you don’t even have to be running Tailscsle on your other devices at home to be able to access them remotely. Works great with things like IP cameras, SSH and screen sharing, Plex, and things like that, too.

1 Like

I added a Qobuz album to my library over Tailscale with no problem. Played fine on my phone and popped up in Roon on my laptop soon after. Since ARC is seeing your core just like it would over a physical LAN connection, I wouldn’t expect there to be any further sort of synching that would have to be done actually connected directly to your home LAN after the initial setup. But we’ve all only been playing with this for about a day now, so who knows.

Mods, this would be a great thread to consider pinning to make it easier for others to find I think.