Tailscale implementation with ARC to circumnavigate ISP CGNAT

yes, I was connected to my local wifi network. I have actually tried multiple times both connected and with wifi off.

I would reboot the core if you haven’t already. Also force quit Tailscale and check it’s not still creating a VPN by looking in the settings.

Thank you. I did reboot the core yesterday. Forgive my ignorance here, but I assume I force quit Tailscale from my MacBook and do I then check my iPhone in regards to the VPN settings?

I meant force quit on the phone to try and connect through your own wifi. If you are running Tailscale on a MacBook I’m not sure how that configuration works as I’m running it on a Synology NAS.

Basically ARC should have worked on your home wifi before you got Tailscale involved. If that was not the case there’s something wrong that has nothing to do with Tailscale.

I found quitting the app does not close the connection on IOS.
The only way is to turn off VPN in settings.

Ok, I understand. That’s what I was wondering as it seemed like everything was installed correctly. I have Tailscale installed on my NAS, I just have also added my MacBook and iPhone as extra machines. So, for clarity, I should be able to get ARC connected to my ROCK when I’m home on my local network irrespective of my internet provider (Starlink) and Tailscale? I know I was unable to do this which is why I started exploring options and discovered this thread.

Thank you, I think I just discovered that myself by simply triggering VPN to “off” on my iPhone settings. I will see if that helps any when I get home and can try to reconnect on my local network again.

Yes, ARC should work on your home wifi without any additional software.

Thank you, that clears up some confusion and frustration but also opens up questions as well. I suppose my next step is to submit a support ticket to Roon to see if they can figure it out? Thanks again for your help and I am still excited to.use ARC away from my home once I can get the other issues figured out.

Not sure what NAS you have but if it does not work may be worth a try to install the core on the NAS as a function test.

It is a Synology NAS. So if I wanted to try that would I just move the core to the NAS and simply power off the ROCK?

Yes if it’s above minimum spec i have it on a 720+.
You need it install the package as detailed below, no reason why tailscale should not work though.


Thanks again. I think I’m going to try to figure out why I can’t connect ARC to ROCK even when I am home on my local network as it doesn’t appear Tailscale should even have an affect in that scenario.

Has ROCK been updated to support ARC? I don’t use it myself, but that’d be something I’d confirm.

Yes, it has.

This looks as if it might be the only way forward for me, as my ISP (EE in UK) uses CG NAT (apparently). I have ROCK on a NUC wired to modem. My data is held on a usb drive connected to the NUC. The NUC is the only machine on all the time (I got it to avoid having to leave another computer always on) so I guess that Tailscale would have to go on the NUC. But how to do that, what version of tailscale I might want, is a complete mystery. Any suggestions very welcome. I have very little understanding of networking BTW (probalby already apparent)

Sorry to say I don’t think that’s possible. You need to have a machine running tailscale and the NUC will only run ROCK.

Thanks for taking the time to answer Andy. I do have a NAS, currently mostly turned off and only on for backups from time to time. It’s a WD MYCloud, so not one of the more sophisticated. Would I have a better chance with installing and running tailscale on there?

Not sure about that model. If it runs apps and tailscale have one for it you should try. The important bit is that it should create a subnet router. You would need to find instructions to do that for a WD Mycloud.

I did think of removing Rock from my NUC and installing Ubuntu server, I could then run both Tailscale and Roonserver on. the same machine. However I found an Raspberry Pi4 tucked away and that now runs Ubuntu with Tailscale. The RPi4 now acts as Tailscale subnet router, the Rock NUC and Roon Arc seem perfectly happy with the Tailscale VPN.