Teac AI-301DA DAC not usable by Mac OS after Roon playback

Not sure really how to describe this in the title.

Setup as follows:

Roon Core & Remote 1.3 running on MacOS 12.12.5
USB connected Teac AI-301DA DAC/Amp
All music upsampled to DSD128.

After playback of music via Roon, the DAC is left in a state of connection of 2-channel 32-bit 352.8 kHz. While connected at this format nothing else in the OS can playback audio. I need to go to Audio Midi settings and set to 192 kHz or less and then audio playback from other software begins to work again.

Is there a way to have this happen automatically?

I have changed the topic to reflect the DAC in question in case others have had or know of this issue.

@support should get some additional interest more immediately from the Roon gurus :stuck_out_tongue:

1 Like

Hi @Astr0b0y ---- Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, may I kindly ask you to please provide/confirm the following:

  1. Can you please share screenshots of your signal path, DSP settings, and device settings when you’re making this observation with the TEAC DAC.

  2. You mentioned that all music is being upsampled to DSD 128, is the experience the same (i.e “DAC is left in a state of connection of 2-channel 32-bit 352.8 kHz”) if you are not this feature?


Hi Eric, here’s the info requested.

a. Signal Path

b. DSP settings (assume headroom management enabled all the time at -4dB, sample rate settings below, all other options in DSP are off).

c. Setup. Exclusive mode is on, all other options are off. Max sample rate and bit depth for PCM are Disabled, DSD over DOP, up to DSD128.

  1. This is where I have issues. If I use DSP to upsample to Max PCM rate or Max PCM power of 2 the output is set to 352.8 kHz and nothing is head from either speakers or headphones. Playback in Roon continues though - progress bar moves forward. I can use Compatibility mode (output is then set at 16-bit 44.1 kHz. I can also use DSD64 or DSD128 which sets output to 176.4 kHz and 352.8 kHz respectively before converting to DSD for output. I can also use Custom settings with all sample rates working except for 352.8 kHz. This would make sense as the DAC supports a mac PCM rate of 192 kHz. The max DSD rate of 5.6 MHz via DoP seems to be the problem here as it appears the Teac reports it has a higher PCM capability to both Roon and the OS.

Hi @Astr0b0y ----- Thank you for your continued feedback and more importantly your patience. My apologies for the delayed response.

Moving forward, I would like to grab a set of Roon and RAATServer logs from you so we can try to pinpoint the cause of this behavior. May I kindly ask you to please perform the following:

  1. Very important - Please reproduce the reported behavior and note the time when the observation is made.

  2. Following the instructions found here, dump us a set of Roon logs and RAATServer logs.


Thanks @Eric, logs have been sent.
I did the following:

Set audio output in Audio Midi Settings to 44 kHz, 16-bit.
I started playback using Roon remote at 19:44 and paused playback around 30 seconds later.

Logs are zipped up and can be found here.

Hi @Astr0b0y ---- Thank you for touching base with me, confirming that the logs have been received and are in our queue to be evaluated.

Once we have completed our analysis, I will be sure to follow up asap with our thoughts/findings. Your patience is very appreciated!


1 Like

Hi @Astr0b0y ---- Thank you for your patience, while our team has been looking into this behavior you’ve reported to us.

Moving forward, based on the analysis of your logs (as you suspected), the AI-301DA is misreporting it’s capabilities to us, so in turn Roon is attempting to stream a sample rate to the DAC which it doesn’t support. Please navigate to the “device setup” window by clicking the gear next to the TEAC Al-301DA in the “audio” tab and setting the max sample rate to 192. This will ensure that all PCM content plays at a working sample rate.


Yes, this works just fine of course. The problem is that because I upsample everything to DSD128, Roon leaves the DAC in a connected state of 352.8kHz.
I would prefe that Roon returned the connection back to whatever it was set to before playback occurred. The same behaviour occurs with the Teac UD-501 which I also own.
Roon should note the system set sample rate before playback and return it to that after it releases the device.

Thanks for the feedback here @Astr0b0y – we understand the request here, and it is something we could implement in the future.

I should note that this would be a complex change, and would require significant QA effort to ensure it doesn’t have any unplanned consequences for other devices. For the moment, I don’t have a firm timeline on when that work might happen, but feel free to open a feature request, so we can keep an eye on how many users are interested in this improvement.

Thanks Mike. It didn’t seem like the understood was fully understood, glad it was.
I appreciate it will take some work on your behalf. I’ll add a feature request.
In the mean time I’m able to use HQPlayer to upsample to my desktop system as it returns the audio to 44kHz when releasing the DAC.