Teething problems

Hello all,

I’d hoped to not introduce myself in this way but I’m afraid I need to ask for some advice.
I’ve just finished setting up a NUC running ROCK. I used the excellent install guide and it went swimmingly.

My only Roon endpoint is a Raspberry Pi3 with Hifiberry DAC+ running RopieeeXL.
I had no problems setting it up and everything seemed to find each other and connect correctly.

I wonder if someone could help me identify a dropout issue.

Roon and Spotify both play through all devices (iPad, iPhone, Macbook Air) with no problems, but as soon as I connect my Raspberry Pi Endpoint, the music will stutter, pause then move on to the next track. This is both local content and streaming.
The Endpoint actually disappears from the list sometimes.
Roon gives me an error box, indicating a potential hardware problem.

Is there somewhere I can start when trying to identify the problem?
I presume its something I’ve not set up correctly in RopieeeXL.
I did try searching as many threads as possible but can’t seem to find what I’m looking for.

The Wi-Fi signal is good (i’d been running the Roon Core on my macbook for the last year with no issues).
I’ve rebooted both the Rock and RaspberryPi.
Rock is connected via Ethernet to the router.

Here’s hoping it’s something simple.
Many thanks in advance,

Welcome to the community, @Mat_Badger!

Are you running Bridge over Wi-Fi? If so, I think this is the likely cause of your problems. Can you connect using Ethernet to see if this makes a difference?

1 Like


Thank you for taking the time to reply, it’s much appreciated.

I’ll check that now and report back.

The Ethernet to Pi is lovely.
Very fast, no dropouts for local or streaming.

I was hoping to use the Wi-Fi from the router to the Pi. Do you think this is possible?

An update to add to the OP.
I’ve noticed that if I use the macbook air as a remote, connected to the NUC core via Wi-Fi and use the macbook audio out then I’m still getting the drop-outs.
The Pi 3 is completely out of the system at this point, so i don’t think its a Ropieee setting after all.

I think it’s painfully evident I’m completely out of my depth so any help would be very much appreciated.

I think this issue is broader than Ropieee, so I am moving this thread to #support for you.

1 Like

Yeah it’s looking that way.
Thanks for having a read.

1 Like

Ok, when I created this topic I assumed it was an issue with Ropieee xl so started it in the correct section.
But after a LOT of reading similar support tickets last night and testing various things I believe it’s a Roon issue.

Someone kindly moved this thread into Support for me but I notice there’s a different protocol for raising tickets.

I’ll mark this one as done and start a new one.


1 Like


Bad idea.

I believe hard wiring the core is preferred.

Roon is quite demanding on network traffic, unless . If you scan the forum for dropout or stuttering you will find in 90% of cases it’s down to inadequate network most of those will be wifi

Roon will work on WiFi but often doesn’t. If you can run Ethernet to the pi then do it. It will be trouble free especially if you plan hi res

Thanks for replying.
My sentence was misleading, the Nuc Core is hard wired to the Router.

But Wi-Fi from there to the Rpi.

Thanks for that.
I am seeing a lot of discussions on this issue!

I might end up running cables, we’ll see.

Also a bad idea. :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.