Teradac Streamer

Purchased a Teradak streamer from Kam Audio with following specs:

Raspberry Pi 4B 4G.
Roon Ready, Roon bridge support

TeraDak Hi-End low-noise linear regulated power supply
Upgraded 2x 0.1ppm TeraDak TCXO clock circuit
High quality R-core transformer
OCC silver plated inside wire
EMI filter for reducing AC power noise
Load protect circuit
High quality power regulation with Rubycon capacitors

If its “Roon Ready”, which hat do I choose? USB works but I can’t get coax, for example, to be recognized by Roon. I tried Allo and HifiBerry digital hats, neither works. The hat has the name Teradak on it.

Did you install Ropieee after installing the hats? Did you select the correct HAT in the Ropieee WebGUI for the audio output and restart it?

Which version did you get the one with XLR and Spdif it uses the same chipset as this one…

AUDIOPHONICS Digipi+AES TOSLINK TCXO Digital Interface AES/EBU for Raspberry Pi

Not sure if Ropieee supports this or not. Try looking for it in the hats menu.

I’ve thought, that on the Teradac Streamer Volumio is installed and there you add the plugin for the Roon Bridge.

Thanks for the reply!

There is a hat called “AUDIOPHONICS I-Sabre ES90*8Q2M DAC” in the Ropieee install which I will try today and report the results.

Doubt it’s the same chipset, but worth a go.

Thanks for the reply!
Volumio was installed but I was told by Teradac Customer Service “…don’t waste time on Volumio OS, remove the Micro SD card and install Ropieee is good choice. Volumio good for non-Roon user.”
I can try reinstalling Volumio and will look for the plugins you mention. Will update today with results.

Finally got the hat to work! I previously had tried “HifiBerry Digi+ Pro” without success. The TeraDak vendor (Kam Audio) suggested I try “HifiBerry Digi+” instead, which worked. I now see the USB and Coax outputs as separate endpoints. Thanks for the suggestions.

1 Like