"The file path is already in use on your system" Can't access my music on NAS even though it's a valid file path [Solved]

Attempting to retire a 2009 Mac Mini in favor of a newer more powerful late-2012 Mini. Used screen sharing from old Mini to new Mini and dragged Roon application over to the new Mini SSD. Started Roon and went through set up, in the process deauthorizing the old Mini as one of the first steps in the procedure.

Under Settings > Storage I put in the exact same path to my NAS as I had before (it’s a static IP so it’s easy and doesn’t vary) along with my user name and password. This file path, user name and password worked fine for Roon using the old 2009 Mini. However, with the new Mini/Roon I get the message “The file path is already in use on your system” and Roon doesn’t load any of the music on the NAS, only Tidal copies of some of the albums I have on the NAS.

I’m probably overlooking something simple, but darned if I can figure out what. I’ve tried shutting down all other computers on my local network, tried shutting down and rebooting the NAS, shut down and restarted Roon on the new Mini multiple times, Disabled and Enabled the path to the NAS multiple times, double and triple-checked everything. . .

Do I need to find a folder (preferences or settings or some such) within Roon on my new drive and delete it so Roon will rebuild all the information including seeing the file path to the NAS as new? I hesitate to start deleting subfolders within the Roon program when I’m not sure what I’m doing.



If all settings will be the same on the new MacMini, why don’t you just copy over your old RoonServer folder from the User’s Library path to the new MacMini?

On same NAS you can limit the maximum connections per user. That would be one thing to check.

A screenshot of your storage settings that is showing the non functional smb line might be helpful.

I appreciate the help; however, baby-steps please.

Where do I find the “old RoonServer folder from the User’s Library path”?

I’ve gone to Users, looked in the Library folder, there is nothing named Roon, RoonServer or anything that looks like a configurations file for Roon.



You should find your old database (including the RoonServer config) in the Library folder of your User’s home directory. It is named “Roon” or “RoonServer”.
Roon should be quitted before copying this folder

How to enter the User-Library folder
The folder is normally hidden, but you can enter it by clicking on the “Go to” menu in the finder. Before you click anything there, hold down the “alt”-button. A new menu icon will appear: “Library”. Click on it and you are in your the User-Library folder. After you clicked “Library” you may release the “alt”-key again.

When you find the Roon or RoonServer folder there. you can copy it to the User’s Library folder of the new MacMini.

Regarding your screenshot: It looks ok. I am still wondering if your shared folder with your music is called “Thecus5500” or if this is the name of your NAS. It sounds like the name of the device (Thecus Technology N5500?) and not like a folder name someone would normally choose to put music files in. (just guessing…)

Thanks very much. I did what I should have done in the first place and looked in the FAQ, which had a brief tutorial on how to move Roon to a new computer. Just like your explanation.

No problems now; playing music via RAAT to a microRendu.

Thecus5550 is the name of that particular NAS – it has only two folders inside, one for PCM music files, the other for DSD music files. So Roon looks at the whole thing.

Appreciate your assistance.


1 Like