The playback stops on file resolution change with USB connection

I am using Roon Nucleus and Nucleus Plus (previously Synology server) connected by USB the the DAC or MUTEC MC3+USB device. The problems is not related to the DAC model, since the same problem is observed with a series of different DAC models. I am observing this issue for a longer time, and reported this here some time ago when using Synology with dCS Vivaldi DAC, but at that time I was moved to dCS support, which however concluded that the USB driver in Synology is too old, and nothing can be done.

In Nucleus however you have complete control on USB driver in the Roon OS, so maybe you can help. Here is the problem described:

In most situation when switching from 16-bit track to 24-bit track (for example 16/44.1 to 24/44.1 or anything else 24-bit long), a short 1/2 second white noise is heard and then the music playback is ceasing. The only way to fix this problem is manually remove the USB cable and put it back again into its socket and press PLAY again.

The problem does not show when using different : press STOP and then PLAY, it appears only when switching from track to track wit hdifferent bit length by using PLAY.

Can you please diagnose the issue and help ?

1 Like

Maybe another instance of this problem?

Roon staff should be able to fix this easily, at least I think so. This problem happens only when . the word length is changing from 16 to 24 and back, NEVER when only sample frequency is changing itself. It is enough to simulate STOP and PLAY, thus introducing a gap between tacks that have a different word length. This will not affect gapless playback in general. Maybe anybody from the programming team can look at this thread and comment on this topic ?
Best regards

Please read that thread, and the discussion by Roon’s CTO of the right fix for the problem (if that’s the problem you are having). In summary, there’s a specific one-line bug in the XMOS firmware that some DACs use that causes this. Roon does not have a reliable way of determining which DACs have the problem, as even different firmware versions on the same DAC hardware behave differently. Setting a delay for every DAC, even ones that do not use XMOS USB, would degrade performance for those DACs that do not have the bug.

Hello @Jaroslaw_Orszanski,

Please read over that thread as @Fernando_Pereira mentioned to see our team’s thoughts on this matter.

To confirm if you are experiencing the same issue and prevent it for the time being, I would enable Sample Rate Conversion on your system and set it to “Max PCM Rate”: