The Roon app will not stay connected to my core

Roon Core Machine

The Roon app will not stay connected to my core. Both app and Core are connected to Version 2.0(build 1128). Any thoughts from Roon support or the community? This has been an on-going issue since build 1.8 when the app would try to connect to a different build version. I’ve tried closing, re-closing, un-loading, re-loading with no long term solution. When I do get it to connect it will disconnect when the iphone or ipad re-awakens. It’s very frustrating. Love it when Roon works.

11 days ago I sent a notice that my Roon remotes will not stay connected to my core. I have not a had a response.
It is still an issue. I run 2.0 build 1133 on the core. When downloading the app for iPhone or iPad, it will load build 1133 and sometimes build 1128. 1128 will not connect of course and 1133 will. The issue is that they will not stay connected as when either device sleeps they lose the connection as they trying to connect to build 1128. This has been on-going for months and I’ve not had any satisfactory responses to clear the issue. I would truly like some answers please.

The Apple App store only allows for 1 version at a time. The above shouldn’t be possible. Have you tried deleting the app on hour device and reinstalling from app store? It should only load 1133.

Then, please fill out the support form and describe your network in great detail. What you describe is usually network issue.

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon Core Machine

macOS Monterey 12.5
iMac Retina 5K 27 inch
3.7 GHz 6-Core intel Core i5
16 GB memory

Networking Gear & Setup Details

XFSETUP-9D88 Comcast router

Connected Audio Devices

Hard wired connection to Simaudio MOON 680D

Number of Tracks in Library

30000 tracks
I have downloaded and deleted numerous times. It downloads 1133 the vast majority of the time. The major issue is that the remote app will return to build 1128 even after downloading build 1133. I downloaded the app again this am. 1133 downloaded just fine, read my core and saw the song ready to play. Within minutes it lost connection and showed build 1128 as the build to connect to.


This is the image from the roon app on my iPhone just now. 1133 was downloaded as stated above, then 1128 shows up. ???

That 1128 is the Core version not the iOS version.

Do you run Server or full Roon on your iMac. This is a core issue not an iOS issue.

Go to your iMac and launch Roon. Settings → About. What version does it say?

This is almost acting as if your Core is downgrading itself (which I’m not sure is even possible) or you somehow got 2 installations of Core on that iMac and that won’t work very well. Let’s troubleshoot the core and make sure its current and healthy.

1 Like


This is from Roon>Settings>About
I run full Roon from the iMac

I have not heard back. Anything we can do to rectify this? What can we troubleshoot?
Joe

Is this screenshot showing the Core running Roon 2.0 build 1133 from the Mac named “Joes-iMac-2”? Do you have a Core or RoonServer running on any other Macs in your network? What about any Mac Remotes?

Can you post a screenshot of Settings → Audio from your Core?


The prior screenshot is from the Mac I’m using as the core.
This is the screenshot requested.
Roon is not on any other iMac on the network.
Mac Remotes? Referring to iOS remotes or what?

Thanks, nothing odd from what I see in your Audio screenshot. Regarding @ipeverywhere’s question, are you running on the iMac RoonServer or the full Roon application as the Core?

Full Roon application on the Core

Are you still having the issues with apparently duplicate Cores having 1128 and 1133 running?

Absolutely. I downloaded Roon app again this morning and build 1128 is what wants to connect

Robert_F
I was hoping for more feedback on this situation. It has been on-going for too long without any resolution. Minimally I thought I’d get response that you guys were working on a solution. One or two cursory replies is not what I would hope for. Can we please try to make some headway on this topic?

@BagelJoe, I am a fellow user user who is a volunteer on the forum. I am tagging @support for you and that will notify the Roon staff for their assistance.

Thank you. Didn’t realize you were a user as well. My apologies if I seemed snippy

No worries, let’s see what support can do for you.

Thanks for doing this.

Hi @BagelJoe,

I have some suggestions. Let’s try to wipe Roon from your system. Please ensure you have solid DB backups before you pursue this.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

After these steps, please download Roon via my link and let me know how things go. Please keep in mind that you will need to install Roon 2.0 on any of your Roon Remote devices/instances still running older or legacy versions after this.

I’ll look forward to hearing some good news from you!

Thanks,
Wes

1 Like

Hi @BagelJoe,

I came across our thread again today and thought I might check on you. Have you had any success with the suggested steps?

Wes