There is an issue loading your Database - [Solved ?]

Core Machine (Operating system/System info/Roon build number)

Roon Core - Nuc running Roon Rock 1.8 Build 756 ethernet

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Remotes - Mac Pro Mac OS 11.2 ethernet
- MacBook Mac OS 10.14 WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB on Mac Pro
PS Audio network Bridge II

Description Of Issue

After updating to the latest version my MacBook was have trouble connecting to Core. Also could not see the MacBook as an audio device as it normally does.

Reinstalled OS from http://rock.local/ interface.

Tried to log in from Mac Pro but asked me to re-login in. Had troubles and rest my password via email.

After rebooting NUC/Rock I logged in but receive a message “There is an issue loading your Database”

What should I be doing?

I restores from backup and it seems to be working now.

However, the space used by my data base has grown by about 50% shown by the web interface but but the RoonServer folder on the NUC has not changed in size. Curious?

Did a clean up but no change.

Is there a way to ensure there are no database issues?

1 Like

Hey @Joseph_Cira,

I’m very sorry for the delay in getting back to you - we all wished we’d get a chance to reply much sooner.

I appreciate you continuing to look into this in the meantime - what you’ve experienced might have to do with a corrupted database. Restoring a backup is the solution - I’m so glad you’ve found it.

Is there anything we can help with now?

Hi @rebeka

There are a couple of us having the same issues. I can’t figure out how to restore from a backup as Roon Only opens onto the “… Issue with connecting to database…” Screen.

Please help!


Thanks for the swift reply - I am very sorry this is ongoing. Could you please:

  • uninstall Roon first,
  • restart your Core
  • follow Dylan’s instructions here
  • install Roon fresh

I hope that works :pray:

Thanks @beka!

I have sent Dylan the logs and followed your instructions which seems to have worked for now. No issues in the last half hour. Ill keep an eye on it and my fingers crossed. I appreciate you getting back to me. cheers

1 Like


Fantastic to hear you’re discussing this with Dylan. I appreciate the update. We’ll be around if you have any updates to share.

Here’s to hoping all will work perfectly :clinking_glasses:

:pray: cheers @beka