There was an error authorizing with Tidal: UnexpectedError. Please try again

Core Machine (Operating system/System info/Roon build number)
NUC10i7 (ROCK 1.0/Software Version 1.7 (build 667) stable)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet connection (Netgear GS108 swithch, D-Link Dir-853 router connected to ISP box)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Lumin U1 Mini, Chord DAVE, USB connected

Description Of Issue
I cannot log back in Tidal. I get the following error message: “There was an error authorizing with Tidal: UnexpectedError. Please try again.” This happens after the web authorization is successful so it’s definitely a Roon issue.
Tidal works perfectly on my PC App and also via web.

This error happened after several attempts to recover the content of a Tidal playlist which suddenly disappeared.

I already tried:

  • Restarting the ROCK
  • Restarting Roon Server Software
  • Restarting the PC used to control playback
  • Deleting the content of the Cache folder in \rock\Data\RoonServer
  • Copying back its content in the Cache folder

I already spent 2 hours trying to fix this @support please help!

Sorry for the trouble here, @doraymon!

What web browser are you using to sign in to TIDAL?

Do you have a different remote you can try using to sign in? Is there any change when doing so?


Hi @dylan, I use Chrome.
Yes I tried with my iPad, no success.

Please logout Tidal from Roon Core, Lumin app, all browsers, and Tidal app in all mobile devices (including your family members’) and computers.

Reboot ROCK.

Relogin Tidal again in Roon.

Hi @wklie , done all of them, but nothing changes. Exactly the same issue, the login is successful on the web but when I go back to Roon it gives me the error.

The only part I don’t understand is how I can log out from Roon Core. I have a ROCK, I don’t log in from core, I log in from a Remote (My PC or my iPad). I logged out from both but nothing changes as mentioned.

What storage device are you using for the ROCK OS? m.2 Transcend SSD?

Please try this:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the RoonServer in the WebUI to generate a new RAATServer

It worked! Thanks Peter!
Can I delete the old RAATServer folder now?

For the records the storage device on the ROCK is a Samsung 512GB 850 Pro 2.5-Inch SATA III Internal SSD (MZ-7KE512BW).
This is recommended by Intel in the NUC manual.

Yes, I think you may delete it if everything is ok now.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.