There was an error checking for an update and track skipping

Roon Core Machine

Mini Mac (2018)
3.2ghz 6 core intel core i7
32GB ram

Networking Gear & Setup Details

Ethernet on Virginmedia Hub 3 router

Connected Audio Devices

HDMI, sometimes airplay

Number of Tracks in Library

737k

Description of Issue

I have a very large library and run roon core on a mini mac with 32gb ram but have an intermittent problem where when i try to start playing an album, it skips through the tracks without playing them or when i try to identify the album to update metadata, it just doesn’t work. When this happens, i notice in the about screen there i a message which reads “there was an error checking for an update” screen shot is attached below. I have wondered if this is a router problem or or a problem with the size of the library on my mini mac. Given the 32 gb of RAM on the mini mac, the fact it’s intermittent and a few other things i’ve observed, i thought it quite possibly was a router problem but i’ve started to think about moving to a Rock setup to see if that avoids the issues. I’ld really appreciate if the Roon support team could try to help me resolve this once and for all.

If you didn’t have such a big library I’d say network but…
Roon support can have a look at your logs, it will be Monday onwards.
Keep a note of the date and time it happens so they can look targeted

Currently, Roon does not recommend a Mac as a Core for large libraries due to architecture issues on the Mac compared to Core architectures on other platforms. However, 737K files is a large library regardless. I agree with Ged, this may require a log review.

I run a Mac and just checked for an update and it was wokring for me. Does this problem still exist for you?

Thanks yes the issue has been intermittent for some time and i kept hoping a software update would resolve it. However, none have and I do have the latest software upload. Yesterday Roon was working for me. I’m getting the checking for update error. If i reboot 1 or 2 time, it will probably clear it but i would appreciate some help with trying to confirm if i have a router issue or if it would be worthwhile to try setting up a rock. Should i wait for someone from the Roon team who monitors the community to contact me or what do i need to do get a log review

I will tag @support for you as this could be a unique issue due to the library size.

Hey @number6mi ,

I’ve enabled diagnostics mode for your iMac to gather logs, can you please use the Roon app for at least a few minutes and let me know afterward so I can check for the log set?

We strongly suggest staying away from ISP-provided routers, so it may just be a networking issue. Other users have had reports of this router causing issues in their setups, please see:

1 Like

Thanks Noris. As suspicious as the size of my library is as a possible explanation, some of the behaviours have always made me think it was network. Anyway i have been into the Roon app doing a few things and the funny thing is it was on it’s best behaviour. Some delay in starting to play tracks when selected to play but no skipping tracks and no significant issues identifying albums. `i don’t know if the was just lucky or unlucky from the standpoint of figuring out what the problem is assuming it comes back. Or maybe the diagnostic mode performs better? I can try again tomorrow. If i did want to try a new Router, any particular model or brand suggestions? I assume this would be the first thing worth investing in before trying to go down the Rock path?

On the router front, I tend to recommend a newer model that may be more than what you need, but that will last a bit longer over time. Don’t know if you need mesh, but certainly an WiFi 6/6E router (although 6E routers a still expensive) that has at least a 3x3 MIMO antenna across both 2.4 and 5 GHz bands (I prefer 4x4 but it can add cost). Netgear, ASUS, Linksys, even the new Amazon Eero or Google Mesh, as long as they are WiFi 6, are good.

Well i’m using Roon today and the error checking for an update message is back

Roon team appreciate if you give me an update on what diagnostics is telling you

Hi @number6mi ,

Thanks for your patience here. I am looking over your logs and I noticed something interesting, which is that you are running out of file descriptors in the logs. Can you please navigate to your Database Location/Core and check to see how large your broker2.db folder is?

Hi Noris,

Thanks for looking into this for me. The size of that file is as follows:

6,462,302,892 bytes (6.47 GB on disk) for 3,449 items

I have no idea what the significance of this is but let me know if that information helps explain anything or there is anything else i should check on my end?

Hi Noris just following up to ask if you had a chance to look at this and reached any conclusions?

Hey @number6mi,

Ben here with the support team stepping in for Noris, my apologies for the delay in our response. I wanted to let you know that our team has been investigating your issue in more depth, and have next steps.

We’ll need you to run a command line utility to better review your files in Roon.

First, head to Applications/Utilities/ folder and open Terminal. From there, copy and paste this line : pgrep Roon | xargs lsof -p >> ~/Desktop/forRoon.txt

From there, export it and upload it here : https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

I’ll be monitoring this thread for your reply :+1:

Hi Ben, many thanks for the update. I have been considering migrating to a nuc with 32 mb ram to see if that would resolve the issue. Any views on whether that would be likely to resolve the issue or the issue you’re investigating might impact that too?

Hi i copied this into terminal and hit carriage return. I couldn’t see anything other than the copied text from before i hit carriage return but i selected export and uploaded the text file to the portal indicated. It wan’t clear to me what the content of the text file was or could have been. Anyway, let me know if you received what you were expecting

Hey @number6mi,

Thanks for letting me know! That is to be expected. Are you able to find a forRoon.txt file on your desktop?

If so, upload that to the link I shared above and we can dig in deeper :+1:

I ran this on my own Mac to see what is the result, but you have to have Roon running when you paste and run the Terminal commands. A set of directories and other information should be in the .txt file that you will need to send to the Roon team. If Roon is not running when you paste the Terminal commands, your .txt file will be blank.

1 Like

Hi Ben
Just checking if you received the text file?

Hey @number6mi,

My apologies for the delay here, our team was able to receive the file. Our team is currently investigating further, I will follow up with more information once we’re able to identify next steps :+1:

Hey @number6mi,

For next steps, I’ve reached out via PM. Please keep an eye out for a message from. Cheers!