"There was an issue loading your database" issue continues

Roon Core Machine

ROCK on Corei7 NUC with 16GB ram and 256GB SSD, nothing else running on the NUC
Library on Synology ds1819+

Networking Gear & Setup Details

GB switch, all connections over ethernet

Connected Audio Devices

Devialet expert pro 440 CI

Number of Tracks in Library

540,000 tracks

Description of Issue

Every 2 days or so, when I launch Roon, I get the error message ‘there was an issue loading your database’. When I restart ROCK, the library is forced to rescan and access is restored, until the next time it happens.
As this has been going on for some time, I don’t have a ‘clean’ back up to restore from (I store 10 backups and add one every 2 days).

Hi there.
When did this start and what Roon build number are you on right now?

It started quite a while back (2 builds ago or so) and I am on the latest build (898)

I have this issue too, and still no reply from Roon hotline. Roon won’t even load, it’s broken. Tried what Roon suggests on their website: Rename the Old Roon, Download a new Roon, install it, Restore the old backup. BUT the Roon takes over and does this: there was an issue loading your database’ and downloads a new file and then it freezes and nothing more happens, and I can start all over again, and this goes on and on… Any suggestions anyone? (MacOs BigSur 11.5.2 and the newest Roon (I wish I never had updated my Roon)

Same issue here as well. Started on Monday/Tuesday. I have a ton of music plus Tidal/Qobuz connections. I really don’t want to lose all of that data.

Restoring backups has not helped. I have gone one by one all the way back to the beginning of January. Each one bombs Roon.

to Pyrexia and KnockKnock: have you tried rebooting Roon Server? Because that fixes it for me (until the next time).

I have the same issue. I have a i5 transporter with the latest version of Roon. I few months back my database got corrupted. It coincided with a Roon update. Restoring a previous database did not work I had to rebuild Roon and then use a previous update. On Tuesday another Roon update was available and after installing this update I received the same error reported in this thread. I then rebuilt Roon and tried restoring a few previous backups. All died in the the conversion to the new database. I’ve been a lifetime member for at least 5 years so and have my own collection integrated in with Tidal. I now do not have access to Roon and that’s upsetting because I really gotten use to the ease of a large digital collection playable in many zones throughout my house. Roon we need your help. We are without our music and that is a big issue for music lovers. I love Roon and can’t be without for days. Please respond back to us with a solution.

rebooting the server. restarting my core. reinstalling the server based on the help article. restoring from multiple backups. nothing is working.

The initial author of this thread issue was resolved. Will we get support on the thread or do we need to start another thread to get this issue resolved? This issue for me and a few others on this thread rebuilt and restored unsuccessfully.

I started my own support thread.

Support wants each support issue in their own thread.

nope, nothing works, even backups from a year ago don’t work

happened the same thing to me a week ago. tried everything as per the insruction. I even created new account but quite frankly happened the same thing. still waiting roon to assist to fix the issue. otherwise roon is really dead with no reason but the latest update …

Hey all :wave:

I’m very thankful that you are keeping us in the loop on how restoring your backups go. We’re so sorry to hear you were affected. We’d love to investigate this in more detail :nerd_face:

If you get the There was an issue loading your database, could you please:

  • restart your Roon Core
  • reproduce the steps that take you to this error message
  • share with us the local date and time when the error message appeared
  • grab a set of logs from you Core, zip up the entire folder and upload it to our drive
  • let us know that you’ve had a chance to follow these steps

Many thanks :pray:

I just uploaded my logs (Patrick Van Osta). The issue occurred this morning (approx 1 hour ago) on 17 feb.
Restarted the core, the app re-scanned my library and everything came back, as before.

It happened again today. Uploading fresh logs.

Hey @Patrick_Van_Osta,

Thanks a lot for replying to the latest post :pray:

We’ve already looked at the logs and what would help clarify the situation would be a screenshot of:

  1. your broker2.db
  2. the database folder size location

Here’s an example of what I mean:

Add images

Here is the brokerdb:

Add images

Here is the database:

Hey @Patrick_Van_Osta,

Thank you very much for the screenshots — unfortunately, they do not shed any light on what the issue might be, as everything seems to be in the right parameters.

I wonder, could you please help us with one more thing? Could you please upload here your Roon database? We’d love to investigate some more.

The instructions to find and zip up your Roon database can be found here: