"there was an issue loading your library" on NUC

I am having trouble losing connection to Roon since I moved. I am now using a Google Home Wifi Mesh system. I have the NUC with ROCK, which worked fine in the old house, with a new Google Mesh system. The NUC is ethernet connected with one of the routers. There is no problem when connected but when I try to open Roon on my IOS or computer after a day or two it says, “there was an issue loading your library”. If I restart the NUC it loads. Any problem solvers out there?

Hi Jason,

I have moved your post to the support section so that it will be seen by support. Can you also fill out the Support Info Form below

Thanks!

-======================================================================-

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Sure. I will do this once I get home.

[quote=“Rugby, post:2, topic:216858”]

Roon Core Machine

see attachment

Intel NUC June Canyon Pentium Kit
1.5 GHz Intel Pentium J5005 Quad-Core
Crucial 8GB DDR4 2400 MHz SO-DIMM Memory Kit (2 x 4GB)

Networking Gear & Setup Details

Google Nest Wifi - Home Wi-Fi System - Wi-Fi Extender - Mesh Router for Wireless Internet and NUC attached via Ethernet

Connected Audio Devices

LampizatOr TRP GA - USB

Number of Tracks in Library

51319 tracks

Roon works fine once I’m on but some days I click on the Roon app on my phone usually first and then the iMac and it can’t find my library and says do I want to restore from a backup. When I just turn off the NUC with ROCK and back on, my library returns.

Just another Roon user here, trying to help.

If Roon tells your that there is an issue with your database this usually means, your database has become corrupted and is toast. You have to create a new one from a backup (I hope you have one or you have to start from scratch).

AFAIK this is only a temporary solution (24 hours then the message reappears) to keep you going until you have time to fix the issue. Please read also:

The core processor is under the minimum recommended specification for roon. An 8th generation i3 is approx 80 percent faster than that pentium.
You may continue to have issues.

I use a solid-state hard drive.

I am using Build 1128

I tried my latest backup from 9/26 last night and this morning the message on Roon homepage was “oops something mg went wrong”. It asks if I want to try a different core. When I do this screen pops up.

Probably that backup is corrupted? I can try an older one before this problem started.

Or is there an issue with the mesh? Where the NUC is Ethernet connection to a router but not the router hardwired connected to the modem. One of the extended routers.

Funny. I was in a rush to go to work and I’m not sure if I did and the oops message popped up again or if I just quit the program and left.

Well it loaded but now I have to add back my NAS storage folder. I hope my playlists are still there.

1 Like

Yeah, I did rename the RoonServer folder to RoonServer_Old so maybe that was it. I readded the NAS and all the folder I have music: itunes, DSD, etc. Reconnected to Tidal. Rescheduled the backups to various locations. Seems to be fine.

Does anyone know how I can get my old Roon playlists from the old Roon_Server folder?

You can restore a backup. The playlists are not separate files you can just move.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.