This morning after Roon update my PI is not visable anymore as endpoint

Hi Harry - well it’s a funny one, I’ve refreshed both Pi’s with XL and all went well. I can’t use both at the same time as I only have one DAC, but the main one is back in position and appears on the Roon list, is enabled, but when I try and play it just doesn’t. Roon says nothing, but the play icon turns back from the pause to the play icon again after a few seconds - no error message.

The weird thing is I notice both Pi’s have (ShairportSync) after the Ropieee name in Roon Audio settings, and I am sure there are far fewer options to configure for the device than usual - of course, all the usual stuff isn’t there, but they don’t show up on any other devices as an Airport endpoint either? Perhaps I did something wrong!

I just downloaded the usual XL compressed zip file and flashed it as normal? They are both fine when accessed by the web interface.

unique identifier 63b668814e3af9f1

Well I had to enable the DAC not the Pi - the Pi on Ropieee was just in the list already as text with no enable or disable button. Panic over… @spockfish :slight_smile:

Anybody know of an easy way to save the flash image somewhere once you have renamed devices and enabled wifi and turned of blinking lights and what ever? Took ages to get this all set-up again…

I’ve still got an ‘cloud-sync’ thingie on the wish list. So you can basically store all your device settings and when you reinstall it it will automagically pull in the settings.

Winter project I guess :wink:


Not sure if this is related, but my main listening Ropieee XL wasn’t found this morning and the Pi3B+ was giving me a steady blinking yellow light.

I reflashed the SD card and got the UI to come up (after pulling an ethernet cable to the Pi. Still couldn’t find a way to use wpa_supplicant or other automated mechanism to set up wifi??). However, as soon as I hit the “enable wifi” toggle the Pi crashed. Tried unplugging to reboot, tried again and got the same thing.

Still stuck with steady blinking light either during bootup or wifi enable. Tried the following below:

  • New SD card and fresh install of latest
  • New power supply

This is with “20200613-ropieeexl-ose_rpi234-stable.bin.xz”

Next up: Try another Pi to see if it’s busted…

(updated with correct Pi model)

Same issue here with the new Roon Build 571 update. RoPieeeXL Pi3 is not in the list of audio players. I went in and enabled it and renamed it in the settings, then updated RoPieee to the latest version now – maybe it would have worked better if I had upgraded RoPieee first. All good.

An unrelated issue I’ve had since February is Tidal is STILL not able to login automatically But that’s for a different thread. :neutral_face:

I have a Pi3 and Pi4 (4GB) and both upgraded and work fine (RopieeeXL).

1 Like

I flashed as well the new stable version Ropieee on my Pi3+ and Roon does not find the device anymore. Connected by LAN.
Roon was updated 2 days ago with their new release

I too had my pi3 running Ropieee disappear. But the allo boss dac was in the audio settings of Roon. Renamed and reenabled it. Works fine. Would try this before reflashing.
Ps have had ropieee on and running for a whole year without any drop outs at all until today. Thanks Harry!

1 Like

Turns out my reflash issue was unrelated. RopieeeXL runs the following curl command and that’s not allowed from my IOT network.

I SSH’d in and killed that process to allow the wifi setup to continue. wpa_supplicant-wlan0.conf ended up with country=UNKNOWN so I updated that manually.

All mine disappeared after yesterdays update, I found out eventually they had all been reset as endpoints so I had to add them all again in settings/audio. Took me while to realise this. Also been having issues with all my ChromeCast endpoints to.