"This track is not currently available" TIDAL error message

Thanks for touching base with me @Brice_Lang and taking the time to answer my questions. Very appreciated!

Moving forward, I would like to enable some diagnostics on your account but would kindly like to first ask you to reproduce the issue 3 times and note the time of day when the error message is received. Once I have the requested timestamps I will go ahead and enable the mentioned diagnostics.

Furthermore, did you get a chance to test wit the DSJ mounted directly to one of your devices? Just curious as to what result that test yielded.

Many thanks!

Errors on the night of 12/4/17 playing Tidal tracks via Roon with MacBook and iPhone as remotes and DSJ as network-connected endpoint:

  • Error–9:03pm
  • Error— 10:55 pm
  • Error—10:57pm. Tried to start an album. Roon kept automatically trying the next track in the album until finally track 4 played successfully.

Then I tried playing Tidal tracks via Roon using my MacBook Pro laptop as an endpoint connected via optical cable to the DSJ DAC. Is that what you were suggesting by saying “test DSJ mounted directly to a device”? I played handful of tracks successfully until… A slightly different error message at 11:17pm, and 11:26pm: “A networking or connectivity problem is interfering with Tidal playback…”

Overall, I’d say that tonight I was able to play more tracks with fewer errors, but obviously, something is still not working right. Worth noting that internet speeds were pretty fast at this time of night. I did a test and got 65mbps download.

Excellent work @Brice_Lang! This is exactly what I was looking for :thumbsup:

As mentioned in my previous, now that I have the requested time frames I will be enabling diagnostics on your account. Once your core machine comes back online the diagnostics report should be automatically uploaded to our servers :microscope:

I will confirm that it has been received and then pass over to our techs ASAP for evaluation.

Many thanks!


i have a new account with roon and have tidal connected to roon. my computer is windows 10.i do not have multi room playback, just one music server that is actually a pc… i am having a problem that intermittently a song i am listening to will stop with the message that it is currently unavailable in tidal even though it will partially play. then the next song will do the same and sometimes many of them.i am not very computer savvy so if someone would help me with this i would appreciate it.i saw an entry earlier of someone who has the same problem… thank you, dan

Hi @daniel_patterson ---- I have moved your post over to this thread as it seems like you are experiencing the same behavior being reported here.

As I have done for Brice, I will be enabling diagnostics on your account so we can try to get better sense as to why you are experiencing this issue with your setup. Furthermore, may I very kindly ask you to please expand on your current setup description using this link as a guide.

Many thanks!

When I’ve seen these sorts of errors I’ve just been able to go back and retry playing the first song that was skipped and it generally works. Seems to be related to some network lag, at least for me, loading the track and Roon maybe “timing” out and moving on.

Unfortunately, it hasn’t been so simple for me. I can’t just make a second attempt at playing the track. The error persists. In any event, it would be unacceptable to just get errors like this so often. A fix of some kind is in order.

1 Like

Completely agree…

We’re looking into this guys – it’s not always easy to confirm whether the issue is happening in the app, in our cloud infrastructure, or at TIDAL, but we’re currently investigating so we can make that determination.

I’m hoping we can confirm exactly what’s going on here before our next release, so if this is in the app we can include a fix, but obviously there’s work to do before any of that can happen. It’s too early to make that determination, but I want to be clear with you guys that we’re aware of this issue and working to resolve it.

If you have experienced this issue, the most helpful thing you can let us know is the time at which it occurred, and what content you were playing, including your region. Then we can enable some diagnostics on your account and check the logs at that timestamp.

More information as I have it – thanks for your patience everyone.

1 Like

I’ve experienced this same issue intermittently over the past year. I haven’t yet found a pattern as to when it occurs, but it seems to take care of itself eventually. I’ll begin taking notes when the issue occurs and forward along the information. Thanks for working on this.

Something I just noticed maybe related to this issue, It seems for me it only affect albums that have synced in from Tidalthat we added via their app and then they sync to Roon. I just added some new stuff today via Tidals app this morning on the way to work. Got home to play them and got this issue., I then used goto to Tidal version in the 3 dot menu menu and it played from there.with no issues. Also noticed when doing this the The add to library option is also still available which is odd since its already added to my library surely that should not be there?

I was playing Sufjan Stevens Illinoise at around 8.45 pm GMT. I am in the UK, but have had this issue at any time of the day. To add I went back to the same album in my collection and it wouldnt play went back to tidal version it played. This also seems to affects any Tracks on an artist page that the songs are in Tidal.

I feel Roon-famous now! :laughing:

1 Like


I also get the same error message but every single time I try to play a tidal track in roon (full install windows 10)… The track plays for a couple of seconds and then stops.

I have no issues with Tidal app alone.

I also have kind of the same issue when I try to play a track from disk (not at all related to Tidal). Even though the error message says something about “an audio file is loading slowly…” Track plays for like 3 seconds

Disk is ssd and not over network… so should not be a problem. And I have not have the problems described above before either, same hardware. I have not run Roon for a while so I dont know for how long it has been like this.

But! Here is the thing. Above issues I have when I run my chord 2 qute dac in exclusive mode wasapi (once again, did not have the issues on this hardware and setting before). If I change settings and run though system output I have no issues. Either tidal playing in Roon or playing files from disk. Which I would like to say means that the error messages we see are really not friendly from an error search perspective. Of course the track is available in Tidal, and also there is no performance issue in transport of the file. It seems like errors come from the playback side, Roon sending data “outside of roon”?

By the way the signal path when running with my chord there are no fancy stuff going on:

Roon says Source–>This Pc roon advanced audio transport --< wasapi exclusive mode

Hope this can give som new ideas into solving this mystery!

Hi again,

This was an interesting glitch. I turned off exclusive mode for my 2 qute, then tried to play a song on disk. Without restarting Roon. Song now plays correctly. I check the signal path… and what? It still says wasapi exclusive mode?
I go back and check the device setup, and yes it says exclusive. I check to play a tidal song. And it works also.

So by turning off exclusive mode, it didn´t turned it off, it instead made exclusive mode work haha. I see the lights on my 2qute verifying all the bitrates also. So im sure its exclusive

Will try to restart roon now and see if it still works.

I did finally experience this error message when using my MacBook as an endpoint, but that is pretty rare. Also, I tend not to get this error once an album or radio has gotten going. The problem is starting that first track. All I want for Christmas is a properly functioning Roon. We’re having Verizon Fios internet installed this Wednesday. It will replace our current Comcast cable internet. I doubt it will impact this Roon issue but I’ll report back if it does.

Yesterday, I installed DirectStream Junior’s brand new firmware RedCloud. Sounds great. However, it had no apparent effect on this error in Roon. Just reporting the facts.

Its becoming very infuriaitng now, cant play a single album from Tidal with out having this issue it gets going eventially after a lot of attempts only to rear its head again at the next album.

All ---- Let me first say, “thank you” for your continued patience while we have been trying to determine the cause of this issue. We understand, and respect, how frustrating these types of issues can be, so thank you for working with us to get this resolved. Secondly, I want to echo what @mike has mentioned in his previous.

As it stands, currently, we have been reviewing logs which were received in diagnostics reports to look for commonalities in the traces when this error message is being generated by the application. Brice has already provided us with timestamps of when the issue had occurred (:thumbsup:) and If you are experiencing this issue still it would be very appreciated if you could provide the same.

“If you have experienced this issue, the most helpful thing you can let us know is the time at which it occurred, and what content you were playing, including your region. Then we can enable some diagnostics on your account and check the logs at that timestamp.”

Again, thank you for your patience and I look forward to receiving feedback/observations.

@daniel_patterson / @Christian_Butler / @CrystalGipsy / @Marcus_Jansson


Hi Eric I am still getting this problem, on my RPI endpoint runing Ropieee. I am on 200mb connection which is fine and I can stream tidal using their app with no issues. This is at 22.15 GMT so not really peak time here in the uk. I am using powerline adaptors to connect to the core and these work fine for everything including hibitrate video and play local music without any issues.

1 Like