Tidal access issues + Roon radio not working - Un-expected error and limited to library

Core Machine (Operating system/System info/Roon build number)

Roon ROCK 1.8 + Roon SW on Windows 10 and Android as end points

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROCK connected to Router via LAN Cable + End points connected to ROCK via 5Ghz WIFI

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

End point connected via USB to DAC

Description Of Issue

This topic relates to my earlier topic which remains unresolved for around 2 months during which time I have interacted with support several times to no avail, unfortunately: https://community.roonlabs.com/t/roon-radio-limited-to-library-after-adding-qobuz-to-my-existing-tidal-service-in-roon-2020-12-22/133042?u=shoaib_ahmed1

In the absence of a resolution, I am opening this new topic so get more eyes in the hopes that my issue gets resolved.

It all started in Dec 2020 when I added Qobuz to my existing Tidal service (Tidal was configured and working fine under Roon). As soon as I added Qobuz, nothing seemed to work (more details in the post linked above). Anyways, I have removed Qobuz since and dont plan to add it as I felt its SQ was inferior to Tidal…to each their own!

In the past 2 months I have provided logs several times, changed my DNSs to Google (as per advice to a Roon rep) and tried to reflash the ROCK SSD and reinstall ROCK several times. This ROCK and Tidal configuration seemed to work great before the day I logged into Qobuz in Dec 2020. Since then, my cache files on the Roon server seem to pre-populate a bunch of files on the blank ROCK as soon as I login to my server for the first time using my Roon ID…I have to remove the file named Qobuz_1.db (or all the cache files) and restart the server via Configuration panel to gain access to Tidal…i know strange and annoying…an experience I didnt buy with my hard earned US$699 for my Roon lifetime subscription.

Moving on…

As of now, I cannot use Roon Radio AT ALL…Period…It doesn’t work (see below pic)!

Also, I cant access Tidal upon restart of the ROCK unless I remove stuff from my Cache folder in the //ROCK file folders (server) and restart the server via the ROCK configuration panel…that too only occasionally. The Tidal’s native app runs fine.

So far, Ive tried:

  • Toggling the ‘Limit to Library button’ in Roon radio (the three dots) on/off;
  • Logging on and off to both Tidal services;
  • Disconnecting and reconnecting the End point PC to the ROCK;
  • Restarting ROCK multiple times…
  • Reinstalled ROCK and reset all Dbs etc…multiple times.
  • Waited patiently for around 2 months for a resolution…

Nothing seems to work. The radio is limited to my Library and nothing seems to change that. I know the songs on which I used to run Radio on to discover new music that dont work now.

Any help or ideas are welcome as my audio experience is all trouble shooting now…


Hi @SHOAIB_AHMED1 ,

Our servers were under a heavy load around the time you posted, can you please check to see if you are still seeing this behavior at the present time?

Hi @noris

I gave it a good 2 days and restarted the server and let it run for 20 odd minutes and here are the observations (below). I also logged in to my Qobuz account in addition to my Tidal to complete the run. I am also sharing the server cache files (all) and the Logs in two separate links below. Anyways, here are the observations:

  1. When i start the ROCK server nothing works (please see below for both Tidal and Qobuz pages)…seems to be an access issue.

  2. When I then restart the server from the ROCK setup page…Roon seems to have access to Qobuz and Tidal.

  3. When I earlier reset (flashed) my ROCK and only installed Tidal (no Qobuz)…a certain file ‘Qobuz_1.db’ appeared to always be downloaded into my Roon cache (fresh server) and I needed to delete that file and restart the server to occasionally gain access to Tidal on Roon.

  4. There are still errors in Roon Radio playback as can be seen in the screen shot…however, after i go through the above ritual…this error seems to seldom occur.

Please see the links below:

Roon Cache: Dropbox - Roon Cache.zip - Simplify your life
Roon Logs: Dropbox - Roon Logs1.zip - Simplify your life

Now the pics:

Tidal Access issues as the ROCK starts and after 15 mins of running on (before server is restarted via setup page):


Qobuz Access issues as the ROCK starts and same 15 mins of being ON:


Roon Radio Issues - before I restart the server:

Roon Radio issue after I restart the server via setup page and have access to both Tidal and Roon (whilst Radio seemed to work more times than not):


Hello @SHOAIB_AHMED1 ,

Thanks for sending the logs over. I took a look through them and I am noticing quite a few network errors.
How does your ROCK Web UI look like, can you share a screenshot (especially the networking section)?

Thanks @noris

So I restarted the ROCK and here are the results (without doing the manual UI based restart as stated earlier). As you can see, the IP is taken but Tidal and Qobuz do not sign in automatically upon restart. I have to press the retry button on the red notification and then even though it seems to login…no data is fetched from the Tidal pages (see Tidal fav screen below). I think we need to reset/delete the cache from Roon’s side…so that my Roon account can be completely reset from back end. I did already change the DNSs to Google earlier. Again, to make it all work (which works sometimes)…I have to stop the server from UI and delete all the Cache files and then restart the server to get access to proper page loading and Roon radio over Tidal and Qobuz.