TIDAL Account Error - Unable to play Tidal tracks

Having an issue with Tidal streaming via Roon. I have received a - Tidal account error - message at times. Also, when clicking play on a record, it will skip through some or all songs and stop.

Also, just tried to play Nils Frahms soundtrack for the film Victoria - I pressed play on the record, and it skipped through to track 6- The Bank. It’s now playing this track. I listened to this record yesterday.

I have restarted the Roon app, to no avail. I have logged out of Tidal and back in with no issue.

I am able to stream music via my Tidal desktop app with no issue.

Any insight?

Ok - in the Settings for my audio I clicked on Use Event Driven Mode.
This seems to have fixed it.

This usually occurs if the tracks aren’t available to stream, usually for licensing reasons. You can use the Tidal app to see if the tracks that were skipped are actually grayed out and thus unavailable.

tidal + event driven have nothing in common… were you also unable to play local files reliably until you used event driven mode?

I’ve got a similar problem, trying to play ‘Cassandra Wilson - Come on in My Kitchen’.
I was playing a Roon playlist where all tracks were TIDAL tracks and they all worked fine (what means, I do not have a general problem with TIDAL). Only the above mentioned song did not work and raised the tidal_account_error.
Same when I tried to play it as a single track.

Playing it in the TIDAL desktop application also works without a problem …

Hey @Matty – just sent you a PM so we can look into this.

A few people have mentioned this issue, so hopefully you can provide us some more information, so we can fix the issue if possible, or at least make the error more clear if it’s insoluble.

Thanks for the report guys!

I’m also getting the ‘tidal account error’ on a number of tracks, although they aren’t greyed out. May be label-related (ECM a particular culprit).

Also two other Tidal-related issues (not sure that this is the right thread):

  • I’ve imported a number of albums to the library, and they mostly show up fine on the screen. One exception (recent Richard Thompson ‘Still’) seems to have imported and is playing fine, but no sign of it on the library…
  • When importing to the library (successfully) often get a blank white screen. Mousing up to the top left shows the three horizontal lines. Click that, and navigate to ‘overview’ and everything recover fine.

(This is all on Build 30)

Getting this today on three or four albums. Not seen before. Checked my Tidal subs up to date (-:

Hey @robfol, @mikeyjfs

Can you guys check the tracks in question on the Tidal website and let me know if they’re playable there using your account? If you can play them from the Tidal website, please post a link back here.

If you’re unable to play them from the Tidal site, this is likely a different issue where our database is our of sync with Tidal’s licensing changes. We’re looking into this one separately, but I want to make sure I have a handle on what issue you guys are experiencing.


Hi mike - The main problem that triggered the post was the Andras Schiff Schubert album (Impromptus, Moment Musicaux, Sonatas) released on ECM in April 2015. I get a tidal_account_error when trying to play it in Roon (although it has imported to the library and looks like any other imported album). When I access it in Tidal, all tracks are greyed out, and there is a message to say that it cannot be streamed although it is available for purchase (although presumably not via Tidal?)

Other issues noticed are with the Mark Knopfler album ‘Tracker’ which I have added to the library (although I can’t find the image on the album browser - only shows up in response to a search) but which shows the same behaviour as the Schiff one above in Roon. However in Tidal it shows up only a few sampler tracks, although those do seem to play fine.

Ok thanks for looking into this @mikeyjfs – this sounds like a known issue, where certain Tidal albums show up in Roon, even though some tracks (or all their tracks) aren’t playable.

We generally filter out albums that aren’t available in a given region, but some albums show up as available even if they can’t be played, which is what we need to look into.

We have a ticket in our bug tracker open for this one, so hopefully it’s fixed soon. Sorry for the trouble!

The ‘tidal account error’ seems to be getting worse here. Can’t now play any of my Tidal albums through Roon, although fine on Tidal itself via the Chrome browser. My own albums are fine.

1 Like

Just as a random thought, given that I was stuck on the Tidal/Roon issue as above, I tried re-starting the Roon app on the core (headless MacMini) Seems for the moment to have sorted the issue…

Does that help with diagnosis of the problem?

Hey @mikeyjfs – what platform are you on? Windows or OSX?

OSX (current version of Yosemite) on both core and remotes

Ok, I’m going to follow up via PM and we’ll figure out what’s happening here. Stand by @mikeyjfs!