Tidal Add to library not working [Solved]

Add to Library from Tidal has ceased to function for me since Roon 1.1 update. Worked flawlessly in 1.0. Tried both from Roon Core & Remote.

Windows 10 on both Core & Remote PC’s.

FYI, It has worked for me with Roon 1.1 and Windows 10 I added some Dr Feelgood.

Hey @LarsS – you’re clicking Add To Library on an album page right? Nothing happens at all?

Hi @mike, it works for most albums but not for all. What I’ve done is that I deinstalled Roon db keeping the application on both Core & Remote PC. Then restart app rebuildig the db which worked fine.

Tried to Add to Library from Tidal what I rembered I had already added eg Lindi Ortega’s album Faded Gloryville. This is not possible and this album is not part of my db. Albums I previously didn’t have are okey to Add to library.

Ok, I just tried that album and was able to add it without issue, so something else is going on here. Are you saying this album was already one of your Tidal favorites? Or that you had the files locally?

If the album was already a Favorite on Tidal, it should be synced to your library automatically when you log into Tidal, and should appear in the album browser. Is that not the case?

Does the album show as a favorite on the Tidal website? How are you finding it in Roon to add? Searching?

Sorry for all the questions @LarsS – just need to figure out what’s different in my setup, and then I’m sure we can figure this out. Appreciate your patience!

@mike, I had the Lindi Ortega album both in Tidal and Roon 1.0. After 1.1 update it was missing in Roon, still in my Tidal. Was not possible to add to Roon.

However, did a clean install this morning and all’s good now. Thanks for support.

Ok great!

Let me know if you see this again – there’s one other thing I’d like you to try here, if the issue recurs.


I have this same issue. I can go to the Tidal App or open in Chrome and select an album as a favorite or deselect and album and the changes do not update in Roon. I moved my Roon folder out of the User Library and tried a fresh install but the issue remains. Any Ideas?

Hi @ckpiv,

It can take some time for Roon and Tidal to synchronise your selection/deselection of an album as a favourite/in library. Deselecting seems slower and more problematic to me than selecting.

You should find that Roon has automatically caught up with Tidal after a few days. If that doesn’t happen or you would like to encourage Roon to pick it up more quickly then you can force Roon to download fresh Tidal information by clearing the Tidal cache.

I’m not sure what you mean by moving your Roon folder out of the User Library. Let’s leave a notification for @mike to check in and see if there is anything further which might assist.

After some further investigation it appears that there is a problem in Tidal with several of the albums I had selected as favorites. Went back to the Tidal app and tried to play these albums but they do not play. They show details such as 9 tracks (41:48) but there are no tracks listed. i.e. Blue Oyster Cult - Cultosaurus Erectus. Strange I picked several albums that Tidal shows but with no tracks. Roon was smart enough to not show songless albums.

@andybob - I moved the Roon Folder out of the OS X User/Library/ to my desktop so I could open Roon and start fresh building my library from scratch to see if my old database was corrupted and the problem.

Ah thanks ckpiv, I’m a windows user so didnt get the terminology. In Windows I think that would result in Roon rebuilding its folders in the original location. Not sure about OS X.

I’ll mark this “Solved” as it doesn’t appear to require attention by devs, but please feel free to post here again or open a new thread if the issue recurs.