Tidal Album Art not displaying [Resolved]

Here’s my system:

Roon Version 1.3,

Core: MacMini (Mid 2011) 2.5GHz, Intel Core i5, 8 GB, OS X 10.11.5 (El Capitan), External iTunes library on Seagate GoFlex 1TB external drive connected via Firewire

Remote: iMac (21.5-inch, Late 2012) 2.7 GHz Intel Core i5 8 GB 1600 MHz DDR3

Connected via ethernet.

Playback is fine.

Here’s my problem:

On the remote:

Album art is inconsistently displayed from Tidal. Images do not fill in when looking at Tidal/What’s New:

Album art is missing from Tidal albums added to library:

On the Core:

(Images taken via iMac screenshot of Apple’s Screenshare of Core running Roon)

Note the missing album art on the top row second from left. I am having the same issue with Brandi Carlile’s new “Cover Stories” album which I’ve deleted and added a few times. Album art disappears after I “Favortie” it.

Here’s a screenshot of Tidal/What’s New from the Core. Different listing but album art appears.

On the Remote when I go to Settings/Setup/Clear Image Cache and select Clear Cache and Restart Now, Roon exits but doesn’t quit. (Still appears in Taskbar) I have to “Force Quit” and restart Roon.

I’ve searched support and this forum on how to clear the Tidal cache. Anyone want to point me where?


It’s in the Settings (from main menu) --> Setup tab, bottom option.

I have tried that several times. Roon attempts to restart but gets stuck. I have to “Force Quit” it and restart it.

Any ideas?

Moving to #support.

Hi @dbtom2 ---- Thank you for the report and sharing your observations with us.

Can you verify for me, if during your troubleshooting you’ve tried reinstalling the remote application on the iMac yet?


No I haven’t reinstalled it. Ya think I should try that first? If so, which files/folders should I delete before reinstalling?

All good here. Simple reinstall after deleting app and Roon library files on remote brought images up fine. Even the Brandi Carlile “Cover Stories” album art. That took a “Delete From Library” and Clear Image Cache restart on the Core but it worked. Many thanks. Tom.

1 Like

Hi @dbtom2 ---- Thank you for the follow up! Glad to hear the reinstall has helped, happy listening!