Tidal Album playable but cannot be added to library

This is a 2-disc album from Tidal which I added to my library some time ago but hadn’t yet played. When I selected the album the option ‘Add to library’ was present to my surprise. However, when I selected that option, the album wasn’t found! Yet I can play it!

To further the mystery, there are 57 deleted files in my Library clean-up list. Needless to say, I haven't cleaned up! Any idea as to what's going on?

(I should add that I’m in Australia.)

Odd. Could be a regional thing. I was able to add it directly to my library in Roon. Have you tried going to listen.tidal.com and “favoriting” it there?

Thanks David. Will try that and then “bounce” Roon. Listening to the album at the moment …

1 Like

That worked. Didn’t have to bounce Roon either. Weird …
Thanks again!

1 Like

I always go into Tidal to favourite titles.

Thanks Henry. I’ve not had to do that before but will definitely keep that option in mind!

BTW, we played this album while trimming our Christmas tree today. Really excellent selection. Thanks for bringing this to my attention. You have great taste in music, @Jan_Wem!

You’re very kind. Glad you enjoyed it!