Tidal album won't add to library [Solved]

I’ve got a tidal album that won’t show up in my roon library.

It was added as a favourite through the tidal gui, but whereas most show up in roon this one doesn’t. I thought it was related to the the ‘new’ albums known issue, but this won’t appear even after pressing (repeatedly) the ‘add to library button’

Any ideas?

Thanks.

Remember seeing this before. I removed it from favs using Tidal GUI then opened Roon and added again, this solved for me. Hope it works for you too!

Same problem… different album:

Tried that with Queensrÿche - Queensrÿche [2013], but it is not possible to add it from Roon, I can click on the “Add to library” button but nothing happens.

Hi VidarDK,

Deleting the TIDAL cache and letting it rebuild can sometimes help:

https://community.roonlabs.com/t/how-do-i-clear-my-tidal-cache/4010/2

1 Like

Hi’ @andybob, deleting cache worked :smiley: thanks.

I’m having a similar problem with this Archie Shepp album:

I can find this album and play it in Roon, but I can’t add it to my library. When I press the “Add to Library” button, it seems to work for a few seconds and then I get a “This album has been deleted - Browse Albums” dialog.

I tried unfavoriting in the Tidal app and then re-attempting to add to my library in Roon, and I also deleted my Roon/Cache folder, but no luck.

It looks like attempting to add the album to my library in Roon results in it being favorited in Tidal, but that’s as far as it goes.

Same problem here. I have removed cache and favorited/unfavorited. Album will add, then delete after a second.