Tidal albums disappeared from Roon - Can anyone help?


I had to restart my NUC running ROCK today and now all my previously linked in tidal albums are not showing in Roon. (1.8)

I have checked that Roon is logged into Tidal and that all seems fine. I have checked Tidal on my iPad and I can see all my albums in the “my collection” section so all good there.

I am able to add and remove albums into Roon from Tidal in the usual way with no problems.

I have also tried the option in Roon under the services > edit > sync library but that does not appear to do anything at all.

If anyone has any ideas that might get everything back to save me having to link them all in again that would be great. Would like to understand what’s happened here so I can try to avoid making the same mistake again.

Many thanks

Update - I tried restoring from a 1.8 backup but this did resolve the issue. I have this morning tried an older 1.7 backup and then allowed Roon to update to 1.8 and everything is now working as it was with Tidal albums showing and playing correctly.

Hope maybe this might help someone if they get the same issue in the future.