Tidal and Qobuz album art no longer displaying on Galaxy Tab A

Core Machine (Operating system/System info/Roon build number)

Windows 10. Core and remotes all updated to latest Roon versions

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All connections wired (except remotes)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi endpoints to various DACs. Allo Boss to stereo

Description Of Issue

Album art for both Tidal and Qobuz will no longer display on Roon remote using my Samsung Galaxy Tab A tablet (latest version SM-T380). However, art from my own library displays fine. Roon use to work very well with this tablet. Everything else seems fine. I can play the Tidal files and I see no other problems with display elements. Oddly, I also have the previous version of the Tab A, with a different screen size, and it continues to work fine. I have reinstalled the Roon remote and core, but no change. All other devices I use as remotes are displaying Tidal and Qobuz art, including iPads, a Fire 10-inch tablet and my Samsung S8 cellular.
My guess is that this has something to do with screen resolution and the latest Roon remote version. Until yesterday I hadn’t tried to use this tablet with Roon for a couple of months. I can see art on the Tidal and Qobuz standalone apps using the tablet. (EDIT: Perhaps not. The tablet has a screen zoom mode. When that is increased album art gets larger but is still blank. It also forces Roon into portrait mode, which is not desirable. So that appears to change the DPI.)
Any suggestions would be appreciated. Thanks.

Hi @Toolio,

Since experiencing this issue have you tried rebooting the tablet?

Please try the following from Settings | Setup:

  • Increase the Memory for Photos/Artwork settings
  • Click Clear Image Cache

I have done both. I have also tried the “remove cache” trick in the core suggested in this group for other display problems. I have one more thought: this may have started with the most recent update to the firmware for this tablet. I updated about a month ago, but hadn’t tried Roon until now.

Actually it’s not just album art. Art for Tidal playlists (relax, party etc.) doesn’t display, either. Technically that’s not album art, I suppose. I just noticed now. Nor do images for genres. Now, strangely, after many hours art for one single playlist art has appeared.

Hi again, Dylan. Problem partially solved. I seemed to be on the wrong track. If I run a VPN on the tablet (there is no VPN running on the core) the art appears on both Tidal and Qobuz. Clearly it’s a networking issue. I hadn’t thought to try that until now. (I’m in Brasil; a VPN to the U.S or Canada works, as does a VPN to Brasil.) I’m not sure why it’s affecting only this tablet, but I suspect the latest firmware has tinkered with the wifi. There’s something in my (complex) network this tablet no longer likes. I should be able to figure out a solution now. So apparently it has nothing to do with Roon, Tidal or screen rez. My apologies for not thinking of this until now. I appreciate your help.
EDIT: Problem now solved. It appears the latest firmware upgrade for this tablet messed up the VPN configuration (in my case, Nord) so it was interfering with Roon connectivity even when not in use. Removing the VPN configuration in settings and reinstalling the VPN app has resolved the issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.