Tidal and Roon Essentials [Solved]

I’m using Roon Essentials with my Elac DS-S101-G. It has been working fine during a few months.
The problem since febr 25th 2017: I cannot use my Tidal account in Roon Essentials.
I do have a Tidal account. I’ve checked it and I can login to the Tidal website.
The Elac is connected to Roon Essentials.
In ‘Settings’ on Roon Essentials I can see: Tidal account not configured.
In ‘Settings’, if I try to login on the my Tidal account, the message appears:
‘Unexpected error, please check your account details.’
How can this be solved?

I’m using:
Roon Essentials on a Windows 10 laptop.
The app Roon Essentials on two Android tablets.
It seems to be not a software problem on the devices.

I suspect that you’re going to have to raise this issue in the Discovery Server forum. This is an issue with the Roon Essentials software running on the Elac server, and I think that first line support for this software will be given by Elac via their support forum.

You could be right, thank you. I’ve raised the problem there too.
Update: the problem has been solved bij resetting the Elac.

Great! Thank you for posting the update.