TIDAL connection problem

My Tidal returned !!!

again don’t connect tidal :frowning:

Hello @Carlos_Francisco_Cec, I’d be happy to help with this!

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

third consecutive day with TIDAL connection problem.

I used

  • Core: NAS QNAP HS-453-DX 8G and I have no problem connecting it to my network
  • Audio outpts: Cambridge EDGE NQ and I have no problem connecting it to my network
  • Controlling Roon: my computer win10 or my smartphone android - its ok
  • No problems im my TIDAL account, I use it normally through my smatphone or my computer connected to EDGE
  • no problems im my network, of course

but ROON loses connection with TIDAL and the services tab keeps turning, turning, turning …

Started working again. But without the roon all afternoon.
The network worked, except for Roon.
I don’t know why

What is your network equipment and how are things connected?

EXO AC2600 MU-MIMO Wi-Fi Router DLINK https://www.dlink.com/en/products/dir-882-exo-ac2600-mu-mimo-wi-fi-router
My NAS, my Cambridge Edge-NQ and my computer are connected via cable Gigabit LAN. My Smartphone via WiFI

again it is not working

But, Tidal works normally :

and Roon Server its OK

Hello @Carlos_Francisco_Cec, thanks for the details and screenshots! I have some ideas to try:

  1. You mentioned a PC and a phone, do you see this on both devices?
  2. What happens if you lower streaming quality under “Settings >Services”?
  3. Have you tried the PC as the core temporarily to see if this helps?

Let me know if you have any questions!

Thank you for your reply and attention
The problem was solved. I did the following:

  1. I restarted the CORE QNAP server
  2. I reinstalled Roon Control software on Win10 and restarted
  3. and now, everything is working
  4. but I can’t identify the reason for the problem

Hello @Carlos_Francisco_Cec, thanks for the steps! I’m glad things are working again. Please let me know if you have further issues.


This evening tidal was deconnected in roon.
when i try to connect from setting/service, it jumps on a tidal page. I connect, Tidal is ok, but when i comme back to roon, is loops and ask me to connect again. Same behavior on iphone and imac.

I’m experiencing the exact same behavior from Roon when trying to log into Tidal

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.