Tidal Disconnection

Preformatted textCore Machine (Operating system/System info/Roon build number)

Mac OS Big Sur/Roon 1.7(build 710)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Gigabit Internet/Ethernet/

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Node2i/Cambridge Audio

Description Of Issue

Every time I add a song from Tidal to a playlist created in Roon, it does so, but immediately after I have to restart to Roon because Tidal gets disconnected. As I restart it connects and plays fine, as long as I don’t add a song from tidal to a playlist. Very frustrating.

1 Like

Hi @Bruce_Elbeblawy,

Can you please provide some mode details here, what do you mean that “Tidal gets disconnected”?
Does no TIDAL content load at all even viewing albums? Does the behavior impact multiple zones and Roon Remotes?

hi there,

What I mean by “Tidal gets disconnected” is that I get the red box at the bottom of the screen saying “Failed to load page” and it won’t show me the tidal section. Once that happens, anything I try to play from Tidal, doesn’t… it just says unavailable. As soon as I restart Roon, everything works perfectly, until the next time I try to add a song from a Tidal to a local playlist… then I have to go through it all again & restart. I don’t use multiple zones, I’m only using one main zone.

Hi @Bruce_Elbeblawy,

Can you please let me know the exact local time + date you see this error occur and then use these instructions to send me a set of logs for review?

Hi @noris
Ok, so the local time for the latest incidents is 7:42 pm, 7:49 pm, and 7:50pm on January 29
The log files are here: https://drive.google.com/file/d/1g8S09KtKl4T-e7KyVdcmPsr4AW-zRJrx/view?usp=sharing

Hi @Bruce_Elbeblawy,

Thanks for sending those logs over, I took a look over them and I’m noticing quite a few networking errors and errors authenticating your TIDAL account due to network timeout. I have a few follow-up questions:

  1. What is the model/manufacturer of all your networking gear? Is the Core connected via Ethernet to the router?

  2. What DNS servers are you using on the router, are you using Cloudflare DNS, Quad9 or Google DNS?

  3. What is the size of your Roon collection (number of tracks / albums) under Overview?

Hi @noris

Thanks for the reply.

  1. I’m using a Arris DG3270 Modem, supplied by my ISP, & the Core is connected via Ethernet
  2. For DNS, I’ve been using a Smart DNS service (Getflix) for the past couple of years
  3. Size of Roon Collection: 5,390 Albums, 86063 Tracks, 1197 Artists

I just tried again now, removed the smart DNS, so straight from my modem, and it made no difference, still the same issue.

Hi @Bruce_Elbeblawy,

Thanks for performing that test, let me ask QA to review your logs and I will get back to you after I have their analysis on your case, thanks!

hi @noris
I know you guys are busy with 1.8, but any update on my situation?
1.8 didn’t fix it for me (there’s lots of other little bugs that have come up, but I’m sure you guys will getting a lot of that!)

1 Like

Hi @Bruce_Elbeblawy,

I did speak to the team regarding your case! Can you please check to see if the same behavior occurs if you try to use a fresh install of Roon for a few days?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Use fresh library for a few days to see if issue occurs
  • After testing, restore from backup

Ok, thanks. I will give it a try.

1 Like

A post was split to a new topic: Audio Loading Slowly on ROCK

Hi @noris
Ok, so I followed the steps. The fresh library worked fine, no problems. As soon as I restored my regular library, the same issues occurred again. What’s my next step here? Do I need to rebuild my whole library from scratch?? I really would rather not do that, as I’ve done so much editing and stuff that I’d like to not lose.

Hi @Bruce_Elbeblawy ,

Thanks for confirming that the fresh database is working as expected, that is good news, at least we can rule out other issues in that case. Do you have any Backups of your Roon database from before the issue you can try to restore?

hi @noris ,
I only keep the last 10 backups, and none of them are from before the issue started.

Hi @Bruce_Elbeblawy ,

I wish I had better news for you, but if you don’t have any backups, then continuing with the fresh database will be the best path forward. We apologize for this inconvenience and if you have any other questions, please just let us know.