Tidal "Error loading album/page/playlist"

I am constantly getting this error message urging me to check internet connection which is fine. I can still play any of the already saved Tidal albums but cannot access any new Tidal albums or playlists

I see that others have suffered this problem and it was resolved mysteriously (ie no comments on what was done to fix it).

PS: I can log into my Tidal account via a Tidal app on iPad without problem.

Hi David,

Try quitting your Roon (or Roon Server) core app and restarting.

Cheers, Greg


Restarting the ROON app on (remote) iMac had not previously worked, but when I restarted the RoonServer on the headless Mac Mini the job was done!

All working now.

Cheers 'n thanks, John

1 Like

Sometimes I have exactly the same problem. And right now it is happening again. Restarting Roon core or even the whole Mac mini reboot doesn’t help at all. Also I’ve cleaned cache folder. Nothing helps. Also I’ve got never ending “Syncing library now” message.

Update: Tried to disable and enable Tidal again. No effect.

I have restarted my Roon Rock, doesn’t help - also app a couple of times…

1 Like

Same here with Qobuz! Error loading page, check network settings. Restarts don’t help; favorites play.

1 Like

seems to be happening a lot of late!!!

Same here with Qobuz. Restart did not help!

Same problem here. I cannot search, the Overview page does not load. But I can stream internet radio with roon. So, the network is there.

Server and client restart didn’t help.

+1 with Qobuz. Restart doesn’t help. :frowning:

Tidal is dead here, nothing in my end changed since yesterday…has Tidal made changes or is this with Roon?

Same here with Tidal. Restarted core and app but no luck so far.

It had to happen as soon as I posted :wink: - Qobuz is now back (but slow). :slightly_smiling_face:

Same issue here, restarted app and core on NUC but no Tidal at all. Logout/login also does not help.

Same here, I’ve experienced problems the whole morning (NLD) with Qobuz, it came back, for about two hours and now it is intermittent, my own collection (on NAS) is working fine and even the metadata is showing correctly.
I have restarted the server (again) and it worked for 10 minutes. Strange thing is the waitlist (including Qobuz tracks) is showing and working, but new releases is intermittent, so not stable yet unfortunately

Same issue for me with Qobuz. Definitely a Roon issue as I can stream internet radio and stream Qobuz by reverting to Squeezelite/LMS.

An hour ago I was streaming from Tidal through Roon. Now I am getting network error from both Tidal and Qobuz. Here at Spain.

Qobuz and Tidal actually work fine from my AURALiC Aries controlled by the Lightning DS app. It seems to be a roon issue.

Yes, I think past weekend we had the same issue.

Search err in Tidal, rebooted my PC (w10). Didn’t help…
Also, random hickups, stuttering… in Tidal.

Tidal app works fine, search, no hickups.