Tidal extremely slow with Roon (Ubuntu)

Core Machine (Operating system/System info/Roon build number)

Ubuntu 18.04.2 LTS. Intel i7-7700t, Asus ROG STRIX Z270I GAMING mITX motherboard, 16GB ram, Samsung 960 EVO 500GB M.2 + 2TB SSD. Roon version 1.6 (build 416) stable (64-bit).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Core connected (wired) to Zyxel Multy Plus, which is connected (wired) to Sagemcom F-3686ACv2. Connection speed 400Mbps.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon end point Sonore microRendu, which is connected with USB to Marantz SA-10 serving as DAC. MicroRendu is connected (wired) to Zyxel GS1900-10HP switch, which is connected (wired) to another Zyxel Multy Plus -unit, which is connected with a wireless connection (wifi) to first Zyxel Multy Plus -unit that has wired connection to the Roon core.

Description Of Issue

All my files located on my Roon core play without problems (fast, no dropouts). However, everything with TIDAL happens very slowly. If a select a song from TIDAL (with Roon) to be played (either to microRendu or to my iPad Pro which I use to control Roon) it takes several minutes (2-5 minutes) before the playing actually starts. When the play starts, it is usually flawless (no stuttering or dropouts). But the starting is just very slow. And this wait typically happens in the same way for the next song etc. I have tried several reboots for the core but no change. TIDAL with Roon has been slow also earlier, but not this slow. This level of slowness has been there for at least one week. Roon doesn’t usually complain anything, once or twice there has been a message saying that TIDAL is slow and there might be network problem. Here is a screenshot of my signal path:


If I play TIDAL with TIDAL app in my iPad Pro in the same wifi network there are no problems (very fast), the same applies to TIDAL with Win 10 browser in my PC connected to Multy Plus similar to microRendu. My roon core machine can access net without problems and download files very quickly.

In other words, everything is working fine except TIDAL with Roon.

Hello @AnttiT,

Thanks for your report and apologize for inconveniences. First thing we should do is to try to understand where the failure is happening. Would you mind to answer the following questions:

  1. What’s your Internet Upload / Download speeds ?
  2. Have you tried to temp move Roon core to Win10 machine ? If not, I recommend to do that easy test. Steps are simple:
    1.Install Roon on Win10 machine
    2.Login Roon account
    3.Deauthorize your Linux box
    4.Login TIDAL
    5.Play TIDAL track



Thanks for your reply. My internet upload speed is typically (also now) between 20-25 Mbps and download speed between 370-390 Mbps.

I installed Roon core to my Win10 PC (that is connected to the Multy Plus as mentioned earlier) and used that to play Tidal with microRendu. The results were somewhat mixed. It worked better than my ubuntu Roon core but not without problems. I quickly tested about 12-15 Tidal tracks. Three of them started playing after about 30 s delay, others started practically immediately. However, one track stopped after 12 s with error message saying that Tidal is slow. I then returned to ubuntu Roon core and tested about 10 Tidal tracks. Three of them started immediately, others had severe delays (one was about 4 minutes, others I did not want to wait).

So, Win10 core seems to be a bit better but it is also showing problems similar to my ubuntu core.

Hi @AnittiT,

Thanks for giving the Windows Core a try.

You mentioned that this issue occurs on the MicroRendu + Marantz, but does the same behavior occur on other zones as well? For example, if you try outputting to “System Output” on the Windows Core, do you experience similar long loading times?

Also, is there any change if you bypass the second Multy unit and connect the Core directly to the primary Multy unit or into the Sagemcom router? Is there a change in that kind of configuration?

– Noris

Yes, there are similar starting delays if I play to USB output with Win10 or if I play to my iPad Pro. It is not dependent on the microRendu. For microRendu or Win10 I cannot bypass the other Multy unit because the primary Multy unit is located in a technical room to where I cannot make direct wired connections. The iPad Pro can access the primary Multy unit with wifi but it does not change things. And Tidal app works perfectly in the iPad, also Tidal with web browser in Win10. And I have a Yamaha musiccast device in the same network and Tidal works perfectly with the musiccast app so this problem seems to be very specific to Tidal with Roon.

Hi @AnttiT,

Thanks for confirming that aspect. I would next like to take a look at the diagnostics from your Core when this issue occurs.

Before I go ahead and enable this mode, can I please ask you to reproduce this issue once more and note the exact local time + date in your country of when the long loading times occur? E.g. 5:39PM on 5/28/19?

– Noris

I can make further tests in the evening, but I just came up with something that may be of relevance. Multy Plus offers IPv6 support and it is on by default. I now disabled IPv6 from the primary Multy and restarted the Ubuntu core. I have only tested Tidal tracks (played from Roon) now with my iPad, but I have successfully started more than 10 tracks with no start delay. So IPv6 support may definitely be an issue here.

With IPv6 disabled on Multy Tidal seems to be playing without any problems to microRendu. So this would seem to solve the immediate problem. However, it might be good to understand why IPv6 is causing these very specific issues with Tidal. Should we do some diagnostics for that?

Hi @AnttiT,

Glad to hear that with IPv6 disable the issue has been resolved!

I have noted your findings with the team and they indicated that the best way for us to proceed is to try to get this reproducible in the QA lab and that diagnostics from your setup won’t be sufficient in tracking down this behavior without us seeing this happen.

We are going to reach out to a few hardware partners to see if we can get gear that displays this behavior and QA will look into this further.

Since the main issue at hand here for you is resolved, I will be marking this thread as [solved] and if we need any further feedback from you as the investigation occurs on our end we will be sure to reach out.


Ok, that’s fine with me. And I can confirm that the situation has remained good. I just listened to one whole album + some tracks with Tidal and did not encounter any delays or other problems.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.