TIDAL has an issue

Core Machine (Operating system/System info/Roon build number)

I have Core in Apple MACBOOK pro

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

I use an Apple Airport WIFI router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

I connect to via WIFI to my active speaker B&W Formation Flex

Description Of Issue

Over a week ago, Roon could not access the tracks in TIDAL, I logged out of TIDAL but was not able to log back in; since then I’ve been trying to connect to TIDAL for few days now… it says “bad username or password”.

A post was split to a new topic: TIDAL Browser Redirect

Does any from Roon can help out resolving the issues??? I’m not sure how this works but I’m very frustrated with the situation…

Hello @Luis_Vermejo and thanks for the information, we’re happy to help! The first thing we should do is verify your login details. Are you able to log into TIDAL directly with your credentials? If you are, please let me know what version of Roon you’re running, and what browser you’re using to sign into TIDAL via Roon. Thanks!

Thank you for getting back to me soon… I’m able to log in directly to TIDAL. How do I look up for the Roon version? I use Google Chrome to log into TIDAL directly. In Roon, I go to “services” to log in to TIDAL.

Luis V

I just figured out where to look for the build. I have 505, it was downloading another version but it stoped and here is what it says now.

Hey @Luis_Vermejo, you could restart Roon to try and trigger the update process again. Make sure firewall and antivirus are disabled if you’re having issues getting the update. If that doesn’t work please let me know and we’ll move to another solution.

It did the same thing. I logged out of Roon, then went to “About”. It started downloading the new version, then it said “Installing” and then stopped and error out…

FYI, my modem is “Netgear”, it was a inexpensive one but compatible with Spectrum.

Please advice…

Hello @Luis_Vermejo, thanks for trying that. I’d recommend making a backup of Roon and try installing the update on top of your current instance with this link. I spoke to another user a bit ago who had this same issue and I’d like to see if it helps here too.

I was able to open the app from your link and updated to build 537. I was not able to updated to build 555 but it let me sign in to TIDAL. I’m now connected to TIDAL. Am I not going to be able to update? It keeps giving me that error message when it try to install it. Can we do something else to update? For now, I can listen to TIDAL in Roon.

Hello @Luis_Vermejo, I’m glad we got you into TIDAL! I have my team taking a look at that link now. While they’re working on that, let’s work on why you’re having issues updating. Could you try Google or Cloudflare DNS and see if that helps? If it doesn’t our next step will be getting logs to my team so we can investigate further.

Can you please let me know if you were able to figure out why I have the problem of installing the updates… It dose download the update but throughs an error when it tries to install it.

Luis Vermejo

Hello @Luis_Vermejo, and thanks for revisiting this topic. Last time we spoke, my theory was that there’s something on your network causing an issue connecting to our servers. Our last idea was to try Google or Cloudflare DNS and then try to get you up to version 571. Since we’ve implemented a new TIDAL login process our first priority should be getting you up to date, which should help us resolve the TIDAL issue as well.

Can you please give me more details when you say Google or Cloudflarr DNS what I’m supposed to do? I used google chrome to download the “core” to my macbook pro.

I’m not that techy… need more instructions.

Thanks for your patients


Hello @Luis_Vermejo, of course! Here are some instructions to follow. There’s a MacOS section slightly down the page.

It says IPv4 or IPv6. I hit “+” and add I tried to update and through same error. Am I following the directions correctly, here is a screenshot

Hello @Luis_Vermejo, could you please send me a screenshot of “Settings>About” in Roon? Let’s make sure you’re running build 571 and not a previous version. Thanks!

I did go a couple of times to see if it will update and install and my build is 537. Don’t have the 571.

Hello @Luis_Vermejo, if you can’t download the latest version, then there’s likely something on your network blocking the connection to our servers. For now, could you please make a backup of your database and let’s try installing Roon on top of your existing instance by downloading the latest version here. Let me know if that gets you on 571. Thanks!