TIDAL: I think this is a bug [Resolved]

I recently changed my TIDAL password, from the Tidal web interface. The next time I used Roon–I think it was the next time, although I’m not 100% sure–I got the “not signed in to TIDAL” message. When I tried to sign in, using my current credentials (including my new password), the log-in failed. I tried several times–no success. So then I went to my TIDAL app, signed myself out, then signed myself back in again with the same credentials. Worked fine. So I tried again. Restarted Roon. Tried signing in to TIDAL through Roon several more times. No luck.

Still haven’t succeeded.


Hi Jim,

Did you get this sorted?

I changed my password on the Tidal website and then went to Roon, logged out in Settings > Services and then logged in with the new password. Everything worked fine for me.

Cheers, Greg

No, not sorted. And just to be sure I didn’t do something dumb, I went and did it again: Signed out of Tidal via the web interface, signed back in with usual username/new password–no problem. Tried it again in Roon; no dice.

Hi Jim,

Let’s flag @support for help.

Cheers, Greg

This happened to me previously and I had to fully disable tidal in Roon, then re-enable.

Hmm, well that’s a bit confusing. Do you have to be signed in to Disable Tidal?

Hi @Jim_Austin ---- Wanted to check in with you and see if you are still experiencing this behavior after the latest build release today. Looking forward to your feedback!


After this most recent update, it works fine. Thanks.

1 Like