TIDAL interruptions on Roon

Core Machine
Mac mini (Late 2015)
macOS Catalina (10.15.1)
2.8 GHz Dual-Core Intel Core i5
16 GB Memory
Roon Version 1.7 (build 505)

Network Details
Apple Airport Extreme 7.9.1
Core connected over Ethernet
DNS set to /

Audio Devices
Naim Uniti Atom (System version connected over WiFi
Cromecast Audio connected over WiFi
(System Output)

Description Of Issue
Roon plays albums / tracks from database on NAS without issues to all devices. When it comes to TIDAL (streaming quality master) however, most tracks stop playing after only a few seconds. The issue persists with all endpoints (Uniti Atom, Chromecast and System Output). Occasionally, I get an error-message along the line of “TIDAL is loading slowly” or “Network Error”. I tried the recommended solutions of setting the DNS to / and deleting the Cache which did not lead to any change in behaviour.

Streaming TIDAL to the Uniti Atom through the Naim-App works perfectly fine without any interruptions.
Streaming TIDAL with the TIDAL App to “System Output” works perfectly fine without any interruptions.

Hi @Stephan_Wehrli,

Welcome to the forum.

So that you are aware, we generally recommend against Apple routers, as mentioned in our Networking Best Practices guide. I can’t say for sure that this is related to the issue, but it is a possibility.

How is the Core connected to the network? Are you using WiFi or Ethernet? If the Core is on WiFi, I would try connecting via Ethernet as a temporary test to see if it helps and try outputting to “System Output”.

What is your internet download/upload speed? Can you run a test on speedtest.net and let me know the results?

Maybe you missed this Noris

1 Like

Thank you @noris for your reply.

  • I was not aware of the issues with Apple routers and I do currently not have another option available.
  • The Core is connected via Ethernet. Thank you @wizardofoz for pointing this out.
  • I have a (very reliable) 10/10 Mbps connection over fibre. Speed-Test gives me 10.8 / 13.8

I just tested switching TIDAL to HiFi on System Output and the Uniti Atom. The interruptions seem to decrease slightly but are still frequent.

10/10Mbps internet (IMHO) is not going to cut it will all that Roon is doing in the background on the wire while you are trying to stream music from Tidal at perhaps any quality setting.

Has your existing library finished being imported and analysed? Roon does a lot of internet data activity especially in the early days or maybe weeks of a new library.

I’m sure Noris will provide some guidance here.

Your input is highly appreciated @wizardofoz I called my ISP earlier this morning and asked for a temporary update to 60/60 to see whether this resolves the issue. I should be able to test it tonight / tomorrow and will certainly keep you posted. My library is a few months old so I do not expect Roon to do too much in the background related to the library. However, as you suggest it might be too much on-demand traffic generated by Roon when streaming from TIDAL.
Should the issue be related to the bandwidth, it came as a surprise as streaming Netflix in HD never posed an issue nor does TIDAL streaming through the TIDAL-app.

Hi @Stephan_Wehrli,

10/10 network speeds would be on the very low side of network speeds, do let us know how 60/60 works for you!

Roon and Netflix use two different buffering strategies, in often cases buffering high-resolution audio content requires more network bandwidth than video, so it is not a comparable test.

Hi @noris
Thank you for your reply and the explanation regarding buffering strategies.
My ISP temporarily increased my bandwidth. Speed-Test now gives me values around 70 - 90 but the behaviour of TIDAL-streaming through Roon remains exactly the same. Most songs drop after playing for a few seconds only (on HiFi quality setting).
Any further advice would be highly appreciated.

Hi @Stephan_Wehrli,

Thanks for trying to stream with the higher speeds. Next, I’d like to take a look at the Roon logs from your machine to see if we can gather more clues regarding this issue.

Can I please ask that you reproduce this issue once more, note the exact local time + date in your country + track that that you notice this behavior on and then manually send me a copy of your Roon logs by using these instructions?

If you don’t have Dropbox / Google Drive to perform the transfer of these logs just let me know and I can provide an alternate upload method. Thanks!

Hi @Stephan_Wehrli,

Thank you for sending the logs. I am taking a look through them and I noticed quite a few networking-related errors. It appears that you PC is timing out when attempting to communicate with TIDAL and our servers as well.

This leads me to believe there could be a firewall or a networking/router issue at play here. Since you are using MacOS, can you please check to see if you have added both Roon and RAATServer as exceptions to your MacOS Firewall? You can use these instructions to check.

I would also make sure that you have set proper exceptions for any other antivirus or firewall program you may have on your PC, I have had reports that McAFee/Kaspersky/Bullguard/Little Snitch firewalls interfered with Roon working properly in the past.

Hi @noris

Thank you for the analysis of the logs. You provided me with the essential hint. After streaming for a few hours uninterrupted, I start to believe to have resolved the issue. While my MacOS firewall was disabled and no antivirus running, OS X introduced a new feature called Screen Time with Catalina. My settings from the iPhone where taken over to the Mac at the time of the update.
Long story short: After disabling all Screen Time features, the TIDAL stream works like a charm again.
I do not know exactly what feature of Screen Time causes the issue but suspect the Content & Privacy feature that - among other things - checks for explicit content.
I ruled out any issue with the Router / Network in general by installing the core on two other machines, both of which had no issue streaming TIDAL (even over WiFi and even though the performance of one of the notebooks does not match Roon specifications). Comparing settings between those machines and the Mac Mini finally lead me to the Screen Time feature.

Thank you again for your help and analysis.

Best regards,



Hello @Stephan_Wehrli,

Thank you for the update here, glad to hear that the system has stabilized since disabling the Screen Time feature. I was not aware of any comparability issues with this MacOS feature, but appreciate you bringing it to my attention, I will also note this in our internal systems in case other users mention similar behavior. Thank you and hope you have a continued enjoyable Roon experience!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.