Tidal is loading too slow

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have a 200 mb/s verified internet connection and lately tracks are skipped and a message appears that Tidal is loading too slow.

Why is this happening?

Hi @Nikolas_Methodiou,

Welcome to the forum, Roon’s support team do not work the weekends so will likely follow this up with you on Monday.

In the meantime, in order for them to give you the best advice can you please supply all the requested details of you setup as requested above.

This can happen if you are using DSP settings that are are pushing the limits of your core’s processing power.
If you’re using DSP try turning it off and see it that helps.

Is your core connected via Ethernet?
It’s recommended to do so.
Although 200Mps seems as if it should be plenty fast enough, Roon requires a very robust internet connection which wifi can’t always provide.

This normally indicates an issue with your local network setup, happens more if your core and endpoints are all using wireless. Speed of the internet connection is not the issue in this regards it’s the ability to pull from tidal and push to a playback zone that’s choking some where. It could be somethings changed network wise, a neighbouring wirlesss system from a neighbour has moved to the same channels as yours and causing interference on your wireless network or your core is being over stressed. Check your Roon signal path to check what speed Roon is processing the stream at if it’s low as 1.2 your in very borderline territory for performance drips. Also some ISPs have fits and starts with some streaming services and their CDNs sometimes jut changing the DNS server to look up via Google’s DNS 8.8.8… in your router can help.

1 Like

Also I don’t use dsp.

Thank you for the prompt answers. All connections are wired through latest version ethernet cables (5 meters long), no wifi is used. The core is my PC which is connected to my dac through a quality usb cable.

This is good advice.
I had streaming issues using my ISPs DNS.
I switched to cloudflare DNS and it was much better.

Hey @Nikolas_Methodiou,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

I wanted to check in on this thread to see if @CrystalGipsy’s note on testing different DNS settings helped with your issue?

If not, please take note of the next time this issue happens, and share it here (Or a particular song). I’ll be monitoring this thread for your reply :pray:

Hi Benjamin,
It is so good to hear from you.
I have a high speed internet connection with no problems at all in every other aspect. As of late, tracks keep skeaping and I get the above message. This happens a lot in some albums and doesn’t happen at all in some others! It is a really weird thing but very annoying as you can imagine. I contacted my ISP and unfortunately the DNS can’t be changed in my router. I can change it in my PC (the core) but when I do that, both Tidal and Roon stop working and I can’t log in. When I return to the auto settings they work normally but the problem is still there.
I would really appreciate your help in solving this since I can’t enjoy my music and your services…
All best,

Hi Nikolas,

After changing the DNS on your PC did you restart it?

Of course I did!

Hey @Nikolas_Methodiou,

We’ll need more information about your full system setup before proceeding. Specifically, what DAC are you using to connect your core, and how is your core connected to your router? Do you use any network switches in your setup? Please give your network and router a hard reboot.

Do tracks only skip when streaming from Tidal? Or, do they skip when playing content from your local library? Please share a few songs that you notice skipping with and share them here.

In the meantime, I would logout and refresh your Tidal service from your Roon settings :pray:

My DAC is the Gustard X16 which is connected to the core (my decent PC) through a 5m Audio Quest Green usb cable. The core is connected to the router through a 5m cat 7 ethernet cable. No network switches.
Tracks only skip when streaming from Tidal, regardless of their format and size. Right now I am trying literally to listen to even a single track from a random album called “MQA Presents the British Embassy Sessions: Eloise mp3”. They all skip and there is significant delay in starting each track and same message appears again and again, “tidal is loading too slow”.
Did the logout and refreshed the Tidal service, unfortunately nothing has changed.
Please bear in mind that many albums and tracks play just fine, the problem occurs randomly in some albums, if I go to another it play fine and then in the next album it happens again etc.
This is very disturbing, how can the problem occur in certain albums only? (always from Tidal).
Thank you so much for trying to help me,

I can’t believe that I am the only one in the world that has this problem…

Album Out of the Blue by System F (any song) plays after many seconds of delay and it skips after a few seconds. In the same time, the other artist’s album from his discography (Champions) plays fine, I repeat, in the same listening session, right after, without changing else. I try changing between the two albums and same thing happens, every time! I am going crazy over this.
Could it be that Tidal draws the music from different servers? Please help…

Hey @Nikolas_Methodiou,

Thank you so much for the information. At this time, I’m unable to enable diagnostics on your core device to take a deeper look into things. Because of this, we’ll need to grab a set of manual logs from your core device. Please use the directions found here and send over a set of logs to our File Uploader.

In the meantime, I would also test out streaming audio directly from your system output on the core and see if you experience similar issues. Anything we can eliminate from your audio chain, test, and replace, will be very helpful as we continue to diagnose.

I’ll be on standby for your reply :+1: