Tidal is slow. Very slow. More errors. Disaster

Tidal stopped working. Please Help.


I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @Custodio_Carneiro,

Welcome to the forum! Can you please use the link that @RBM posted to provide some more details regarding your setup?

Is there any change in behavior if you log out and back into TIDAL via the Roon Settings -> Services tab?

Hello. Tried everything. Clear cache, Uninstall Roon server, Google DNS…

It looks like the problem started when The number of Tidal Albums increased inside my Roon Library.

My setup:

NAS > Asus Router > Macmini(Roon Server) > Asus Router > Hp switch > Macmini 2(Hqplayer) > Interface/DAC. Control with Roon Remote(iphone).

Best Regards,


Hi @Custodio_Carneiro,

Do the errors only happen when you’re playing to the HQPlayer zone? What if you try starting playback to the Core Mac Mini’s System Output zone (the internal speakers), do you see any issues with that zone?

Total failure. The problem starts when I add a Tidal album to the Library.

Hi @Custodio_Carneiro,

You’re going to have to be a bit more specific as to the exact symptoms you’re having, can you please provide more info? Playback doesn’t work at all? Loading any TIDAL albums is an issue?

One other thought here, have you confirmed that TIDAL is still working as expected outside of Roon? For example, are you able to start playback on the Mac Mini Core if you open a web browser and go to the TIDAL web player (listen.tidal.com)?

Sure. Everything works fine untill I add a Tidal Album to the Library.

If I play the Tidal album, the whole software collapse. Even the Files inside my NAS.

I can Play Tidal Albums If I go directly to the Tidal link inside Roon.

The software stopped working suddenly. The difference from the time it was working and the moment it “crashed” was only the number of Tidal albums inside my Roon Library.

P.S: Just an update. The Tidal link is better, but it also has problems. It becomes slow after the third song of an album.

Hi @Custodio_Carneiro,

Can you please reproduce this issue on your Core’s System Output zone and let me know the exact local time + date + track of the issues occurrence?

Once I have this info I can enable diagnostics mode for your Core and take a look at logs to see if we can gather some more info that way.


15:17, Brazilian time.


Bass Folk Song, The essential Stanley Clark

Hi @Custodio_Carneiro,

Thanks for letting me know that timestamp. I took a look over your logs and I noticed that you got a network timeout from TIDAL when this issue occurred:

5/05 01:54:23 Warn: Error in web request https://api.tidal.com/v1/users/29779700/favorites/albums?countryCode=BR: NetworkError (The operation has timed out.)
05/05 01:54:23 Warn: [tidal/http] POST https://api.tidal.com/v1/users/29779700/favorites/albums?countryCode=BR => NetworkError The operation has timed out.
05/05 01:54:35 Trace: [HQPLAYER MAC] [Enhanced, 16/44 FLAC => 16/44] [100% buf] [LOADING @ 0:00] Um Canto - Casa7
05/05 01:54:36 Info: [stats] 5440mb Virtual, 1027mb Physical, 310mb Managed, 93 Threads,  FDs 
05/05 01:54:41 Info: [library/albumdetails] Created album details screen for LibraryAlbum[207407, Varga Gabor Jazz Trio - Old School Mission]
05/05 01:54:41 Info: [library/albumdetails] a6003831303338353330, c80035393939383833303433383531

It also looks like you are getting timeouts when trying to communicate with our metadata servers, so I suspect there is a networking issue here. Can you confirm you have the latest firmware installed on your router? How is your Core connected to the router, is it via WiFi or Ethernet? If it’s via WiFi, I would suggest temporarily trying to connect it via Ethernet to see if it helps.

Everything is connected by cable.

The router is updated.

My network is working ok.

Your software with Tidal is the only problem I have.

I will try a hard reset to my router.

Good Lord.

Hi @Custodio_Carneiro,

Has there been any change in behavior after rebooting the router?
I would also try playing to non-HQPlayer zones to see if this behavior just impacts HQPlayer.

No. The hard reset did not work. Time to cancel the Tidal signature.

Hope you make a solution for the next upgrade. Too many similar problems from users here in Brazil.

Kind Regards,


Hi @Custodio_Carneiro,

Sorry to hear that the suggestion hasn’t helped.

You mentioned that you previously uninstalled RoonServer, but if you want to try a complete reinstall of the database, you can use these instructions to do so:

  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall RoonServer from our Downloads Page
  • Configure the new database

Still not working. Anything else?

I can only enjoy your software if a disable Tidal.

Hello. I think I found the problem.

I disconnected the network cable from the modem of my internet provider.

Tested it with a network cable tester. It was ok. Reconnected it to a different RJ45 output of the modem. VoilĂ . Now it works.

Looks like a Poltergeist thing.

1 Like

Hello @Custodio_Carneiro,

Thank you for the update here, that’s wonderful news!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.