Tidal Library not synchronising

Roon Core Machine

Core Machine is ROCK on an Intel NUC, Version 1.8 (build 903) stable

Networking Gear & Setup Details

Core and end points are mostly hardwired, no managed switches in the loop.
The only network oddity is I run a Pi Hole DNS ad blocker on the network. I have checked the logs here but can’t see any Roon/tidal traffic being blocked.

Connected Audio Devices

Multiple network connected devices, including:

  • Airplay Surround reciever
  • MicroRendu
  • Google home devices

Number of Tracks in Library

around 33k tracks

Description of Issue

I have been using Tidal / Roon for a number of years with no major issues. For the last couple of weeks I have been having problems with my library.

I often look through Tidal and heart albums from Tidal, to listen to them at a later date through Roon, recently it looks like these items aren’t syncronising and adding into Roon. I have had to get home and then add the album through the Roon interface.

An example of my Tidal and Roon albums, sorted by date with no filtering:

In settings my tidal library seems to be constantly listed as syncing

Steps to attempt resolution

  • I have logged out of tidal in Roon, and tidal and logged all services back in.
  • I have disabled and enable tidal from the roon services
  • I have restarted my core numerous times.
  • I have tried the refresh function in the Tidal menu in Roon, multiple times
  • I have disabled pi hole to remove this from the equation.

I have no issues streaming from Tidal and no other network issues, so I don’t think this is the issue.

None of these have any any effect, can anyone help?

As in Log out of tidal, REboot the Roonserver, and then log back into Tidal?

I logged out of tidal in services, then out of tidal in tidal, and the rebooted and logged back in, in services

To be honest I have been trying all sorts over the last 2 or 3 weeks since this started.

Every now and again, this also happens.

Hi, @Matthew_Clegg, thank you for your report. Do you mind if we pull a diagnostics report from your Core? The last screenshot of yours indicates a networking issue. We need to take a look at Roon logs to get a better understanding of what’s happening on your Roon Core.



Of course Ivan, how do we proceed?
The last issue is very intermittent, and I suspect it is due to rate limiting on DNS requests on my network. I have rebooted the server and it seems to have cleared, though the library is still noy syncing.

Thanks, @Matthew_Clegg, I will send a request via our support system and I hope that your Core will be able to send the data to us. After this, we will analyse it and @david.p should come up with the next steps.



1 Like

Hi @Matthew_Clegg,

We checked your core logs and found this request.

02/23 01:28:34 Trace: [tidal/storage] sync completed unsuccessfully in 20862ms: Result[Status=NetworkError]"

This means that your TIDAL account cannot finish the syncing procedure. After looking around this line in the same log, we noticed a lot of these errors which are intermittent:

02/23 01:28:38 Warn: [easyhttp] [1112] Get https://metadata.roonlabs.net/1/albums/166:0:304838/tracks?c=tidal-gb web exception without response: Name or service not known (metadata.roonlabs.net:443) Name or service not known (metadata.roonlabs.net:443)

It points to a DNS-related issue. As the next step, we suggest temporarily turning off the Pi Hole DNS adblocker. Let’s see if that helps.


Ok, I can do that but the IPv4 requests all went through at that time, and Pihole and Roon have been working fine for the last 6 months.

Let me have a look at reconfiguring it and will come back to you

Ok, so I have set Rock to bypass the Pihole by using a static IP (Pi hole also serves DHCP) and setting the DNS up be google (

That has fixed the problem, and does point to a problem with the way pihole is serving DNS.

I would love to try and understand why, since it looks to all intents from the logs that PiHole is responding to A record requests correctly.

Have you come across anything similar, I will trawl the forum. Any thoughts? Could it be anything to do with the IPv6 (AAAA) requests that are failing with no IPV6 DNS results returned?

I am also interested if anything has changed at your end, as pihole and Roon have coexisted for the last year.

I could not get Qobuz or Tidal to work with Pihole when I tried
it out recently. Not being the greatest expert in these things I just abandoned it and removed pihole.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.