Tidal library Syncing problem


Since last Saturday i have a syncing issue with Tidal.

System description:
cable modem - AsusR68T router-NUC6i5 running Ubuntu LTS16.04 - Auralic Aries - Lyngdorf TDAI2170 usb input. All wired with CAT5e. QNAP TS251 for local albums. Daily auto sync to QNAP in Home2.
Roon lifetime subscription.

VDSL modem/router - NUC6i5 running Rock 1.5 build 334 - Allo USBridge - Lyngdorf TDAI2170 usb input. All wired with CAT5e. Remotes are Android phone & S2 tablet and Surface Pro4 W10.
Music stored on QNAP 209. Approx 400 albums. Tidal Hifi family subscription with approx 1050 albums in Library.
Roon annual subscription.

The problem
I’m currently at Home2. I cannot check the behaviour in Home1.
The problem started last Saturday.
Tidal library is no longer syncing well. I still can play Tidal music from my Roon library but do not see any Tidal albums in Roon/Tidal/New or in Roon/Overview.

What did i try to do:

I have restarted my QNAP NAS Saturday (before the sync failure) but i do not see the relation with my problem.
Reboot the modem/router, reboot Rock and the remotes.
Log out of Tidal and signed in again
Checked if Tidal app is working flawlessly-Yes
No action did resolve or change the problem.

Please give me any guidance.

Hey @Jules_Herfst — Thank you for reaching out and sharing your report with us!

Does the sync status ever change from “Syncing library now” or does it seem to be stuck there?

I’d like to recommend clearing your TIDAL cache and seeing if there are any improvements. Please see the steps below:

  1. Shutdown your Roon Core
  2. Find and open your Roon database
  3. Navigate to /Library/Roon/Cache
  4. Move the contents of the /Cache folder elsewhere, like your desktop
  5. Try restarting Roon and syncing Tidal

Let me know if you see any changes after doing this.


Thanks for your prompt reply Dylan,

The sync status does not seem to change. It remains syncing.

i could not find the path /Library/Roon/Cache.
I deleted the content of \ROCK\Data\RoonServer\Cache.
Album overview changed however.
Now i have 525 albums in library.


Hi Dylan,

Confusion grows,

I logged of from Tidal once again.
Some Tidal albums remain visable in my Album view.

Then i decided to clean my Roon Library in the Settings menu.
Not working however.

Thanks for the info, @Jules_Herfst!

I’d like to propose a test to see if this behavior occurs with a fresh database. Please see the steps below:

  • Create a backup of your Roon database
  • Locate your Roon database according to these instructions
  • Rename the entire Roon (or RoonServer) folder to roon_old
  • Relaunch Roon, sign in, and configure a new install
  • Login to TIDAL and try to sync / browse the TIDAL section of Roon

Let me know if you continue to have difficulties after trying this out.


OK, i followed your instructions.
All seems normal. Library is restored and Tidal is synced. Can i savely restore my back up?
I want my bookmarks, internet radio stations and my tags back.


Hey @Jules_Herfst,

Yes, go ahead and restore your backup now. Let me know if the issue comes back or if you’re able to continue using TIDAL like normal.


Unfortunately it didn’t work.
Bookmarks etc returned but also the Tidal syncing problem.
My back up was made today when i was not logged in at Tidal.

I left it syncing a while but then the Roon app and Rock webpage were no longer accessible. I had to reboot the NUC and after i could reinstall Roon.
It is now building the library again.

Thanks for the info, @Jules_Herfst!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more (try accessing the TIDAL tab, as well as syncing TIDAL) and note the time at which the problem occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Hi Dylan,

Today (09:20h) i repeated the steps you adviced me to do.
Roon & Tidal working well after. Bookmarks etc. missing.
After restoring from back up things go creasy.
I tried several things including restoring from a 3 month old back up and removing tidal folder from cache.
Nothing worked well.
Finally i started all over again and restored my bookmarks and internet radio stations manualy,
Roon&Tidal working as expected.
It’s frustating not being able to understand what went wrong. I do not want continue to tinker around again, i want to enjoy music.

Thanks for your support. Much appreciated.

3 posts were merged into an existing topic: Tidal Sync tonight