TIDAL login failed lately

Lately ROON fails on Tidal connection with “login failed” error. However TIDAL continues to work normally on the same machine. So apparently it is not a problem with Tidal but with Roon itself. Anyone having this problem ?

I guess, if nobody answers they havn´t any problem with TIDAL. My login works in Roon.

I’m having a problem with Tidal as well. I got the same message as some others (cannot login). And then I made the fatal mistake to ‘logout’ to try to login again. This is now failing all the time :sob:

When I go to Settings/Services and choose Login for Tidal the website opens properly and I can login to Tidal. It then asks if I want to open with Roon, I say ‘yes’ and nothing happens.

I’m on various Apple devices (iPad Pro, iPhone 11 Pro and Macbook) so I thought it might be a Safari issue. I’ve changed my default browser to Chrome on the Macbook, but still nothing happening in Roon.

So I can’t play Tidal anymore!!!

Anyone having a suggestion on how to solve this?

Albert, your description fits exactly my own experience. I am able to login but then nothing happens. On my iPad i cannot see anything else but on a PC you can see “wait to return automatically to Roon” but this never happens. If you return to Roon by hand the things stay the same,i.e., no connection to Tidal. I dont know why but after a hour or so trying everything, i decided to disconnect the router and recycle it. Thereafter Roon connection to Tidal worked! Why? I dont know.

@inaki_castillo thanks for your suggestion. It didn’t help in my case.

The Tidal app itself works fine on every device. And the login on the site as well. Roon also works fine on all devices.

I run Roon on a QNAP TVS-473e and have re-started it two times now. It is on 1.8 build 764.

I have also restarted the Unifi Dream Machine Pro and USW-Pro-24 (router and switch). This didn’t help.
Roon works fine with my local music. Only the Tidal service doesn’t work anymore.

Another problem with Roon+Tidal is Roon complaining about “this track is not currently available from Tidal”, while on Tidal the track IS available and plays.


Is it possible that Roon tries to login with an older(trial?) Tidal account?

+1 I’m seeing the following sequence of error messages when trying to play a Tidal track (no issue playing local files)

“Unexpected error communicating with audio device”
“Too many failures stopping playback”

1 Like

This track is not currently available in Tidal” is happening so much, this afternoon, that Tidal is effectively unusable.


I am having this problem too… Very frustrating.

My biggest problem at the moment is that I cannot login to Tidal anymore at all.
So I cant use Tidal anjmore.

I’ve used up my Quobuz test month already. Maybe I should try again with another temporary address to see if that service still works.

I’ve now als posted my login issue over st the Support channel.

Here in Switzerland, the Tidal login with Roon is also not possible. Even I, as a Roon fanboy, am getting a bit p…d off!

Same issue here using Windows 7 server and Android Samsung. On the server seems I’m successful with login then it kicks me to a http page that says Hello. With the Samsung successful with login but kicks me back to Roon settings Tidal login page.

I’m having the same issue - not recognizing Tidal login. I login on a web browser as prompted; it redirects me to open Roon and still - NO TIDAL.

Similar problem here. Got a message in Roon saying I was no longer logged into Tidal. So I logged out and tried to log back in via Roon. After login at Tidal, I get taken to url: https:// oauthcb.roonlabs.net/2/tidal/authorize?code= ( then a long string) and a message displays on the page: non-200 status code from Tidal, code: 400
Searching the forum I think this issue has happened before - some time last year and in January this year. Unfortunately, no solution was posted and the problem seemed to go away after a couple of days.
I emailed Roon support and they asked me if I can login to Tidal on its own, which I can and I told them so. Waiting to hear more.

same issue for me, Tidal login failure via roon. Tried logout/login, get splash page saying successful, but doesn’t register in settings>services. Local library playing fine. No issues with streaming via tidal app on it’s own.

HP Hexa-core 2.0GHz
Windows 8.1
Running roon complete 1.8.764
USB connected DAC

Same problem here

Yes, I have the problem today 17/03/2021, I am connected to Tidal but fails through roon

I have the same problem. After login out in Roon I am not able to login to Tidal from Roon anymore. Message from Tidal says login in Ok, but in Roon not. Seperately login in in Tidal functions.

I am in HK and I am a lifetime member. I have the same problem logging on to Tidal. See below:IMG_20210317_174244|375x500 ![IMG_20210317_174253|375x500]

Now all my Tidal album disappeared. I have no problem logging into Tidal by itself.