Tidal login failure after changing network gear [resolved: network issue w/ ip settings]

Core Machine

ROCK Version 1.0 build 227

Network Details
Unifi Dream Machine Pro Version 1.10.0 connected to an ATT BRW320 fiber modem in passthrough mode. ROCK is connected to this via ethernet/Unifi 16 port POE switch;

Audio Devices


Library Size

Not currently connected (but less than 2500 tracks).

Description of Issue
Roon was working on my wired network with a basic Netgear 8 port switch connecting my audio gear. I implemented a Unifi network with the UDMP and the ROCK now is attached via ethernet to a 16 port Unifi switch, which is connected to the UDMP. After getting the new network set up, I connected ROCK. When I started the Roon App on my Lenovo laptop (Windows 10 64bit) I got the error message that Tidal login failed. When I try to re-login I get into a loop where it appears that the login is successful, but Tidal doesn’t connect. I get the “non-200 status code from Tidal, code: 400” error message. When I login directly with Tidal using my credentials it logs in fine. I also get similar behavior on my Pixel 3 running the latest Android software.

I have searched through the community posts where the same symptoms occur and tried the various fixes, but none have worked. I have uninstalled and reinstalled Roon, cleared cache, restarted ROCK and the UDMP (multiple times in different orders) and deleted the Roon cache folder followed by restart. I also looked for the Tidal_account folder, but couldn’t find it. Based on that I double checked my Tidal account and it shows as active and to be renewed monthly.

Let me know what info you need to get this fixed.

are you using the same IP address ranges and DHCP plus DNS setting?

I’ve run Unifi and UDMP with all manner of Roon cores (incl ROCK) and its all good.

Tidal, Qobuz (and Spotify for that matter) all work too

Go over your Network and settings and make a not of what what IP wise especially for ROCK and DNS too - use or ideally

screens shots might also help

Thanks wizardofoz. I have everything in the 192.168.0.x IP range and the DNS setting is But you got me thinking . . . I was seeing the ROCK but I wasn’t sure it was seeing the internet. I tried the Internet Radio stations (which I rarely use) and they didn’t show, so no internet (Doh!). I went back to the ROCK settings page and to get started with some checking, I changed from a Static IP address to DHCP (I liked knowing I could always bring ROCK screen up with the same IP address). Once I did that it connected to the internet and everything now works. I’m not sure why that solved the problem, but I’m up and running. Thanks for your help.