Tidal login failure since software update [Resolved]

Core Machine (Operating system/System info/Roon build number)

Mac Mini using latest OS

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

High speed internet (fiberoptic) and wired network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

optical digital output to Linn Majik DSM, amp and speakers

Description Of Issue
For the past two months, every time I launch Roon it tells me that Tidal login has failed. I click retry, but that fails. I click edit and sign out of account, then go to sign back-in. When I do it launches a Tidal web page to login. However, when I enter my email address and hit enter, it automatically logs me in without having to enter my password. This tells me that it’s logged-in the whole time and that something has changed in how Roon accesses my account, which used to be entered/saved in Roon services. I’ve changed nothing with my Tidal account but after two months of this process, I’d like to get it sorted out. Any ideas?

The tidal login problem is known in various variations.

Thanks MrSalieri. Is there a solution that you know of? I really don’t want to have to uninstall/reinstall Roon.

Last update helped me a bit. In general, the problem is known, the roon team is working on a solution.

Hello @Kelly_Larkin, and thanks for your report! What version of Roon are you running currently?


Thanks for getting back to me. I’m using Roon version 1.7 (build 571) stable. My Roon says I have the latest version installed.

This problem has existed for over 2 months. I’ve had to jump through numerous hoops to get Tidal (hiFi) going again on Roon, and it’s getting really tedious. Can you help?

Thanks, Kelly

Anything further to add?

Hello @Kelly_Larkin, I spoke to the team and they’re aware and there is an active investigation in progress and QA is looking into what improvements can be made in this area of the login flow.

We appreciate your patience while this investigation is ongoing and apologies for the inconvenience of having to re-login when the Core is rebooted in the meantime.

Thanks very much. I’ll sit tight and await the results of your investigation. K

So I’ve solved the problem myself.

I had a new issue with Roon: a question mark over the icon on my Mac Mini when I tried to launch the app, so I simply deleted the Roon app from my system.

When I re-installed Roon from scratch, the Tidal problem went away, ending my 3 month inquiry into the problem. Hope this info helps other Roon users experiencing the same problem.

1 Like

Hi @Kelly_Larkin,

On Wednesday we released a new version of Roon which included some improvements to how TIDAL and Roon communicate. This likely helped to resolve things as well after you reinstalled the latest version. Glad to hear all is well now!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.