Tidal login issue on NUC


I am now a happy owner of an i7NUC running the ROON core and making great sounds using microRendu!

The NUC sees the USB drive with my music library as expected and plays the albums… Fine!

Now, I have a slight issue…
Every time I try to login on my Tidal account in the “Services” tab, an error message is shown, see attached screenshot.

I can see that there are a few suggestions in the community! - but I am not sure what suggestion to follow…?

Login to Tidal from other units works fine.

Please let me know what cure to use for this problem.

Thanks a lot in advance:)

Kind regards,


Hi @LucasM,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since experiencing this behavior have you tried rebooting your Core machine?

Hi Dylan
Thanks for your reply.
First attempt to cure this was a reboot and after I tried to switched on and off, but no cure…
I have attached a drawing of current network and I hope it makes sense…

I look forward to your further instructions and/or questions…
Thanks a lot in advance

Hi Dylan
Just an idea…
The initial setup was made on a different network than my homenetwork…
My colleague was very curious, so we installed and setup ROCK on the NUC at work, on the guest-network and stopped when we needed the microRendu to get further… Then I continued when I came home:)
Could this be part of the issue?
Kind regards,

Thanks for the update, @LucasM,

Moving forward, I was hoping you could try the following:

  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Hi Dylan
Instant cure - Thanks a lot!!!
Just for the record: The Cache I deleted (Moved to a quarantaine folder) was found almost as you suggested, but it did the job, so I think it is OK:
Now everything seems to work fine and I am happy, both with Roon and NUC.
Thanks again!
Kind regards,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @support
This issue is NOT solved - Sorry!
After shutdown and restart of the NUC, the problem occurs again, see screenshot from mobile:
If I clear the Cache as suggested in linked topic, Tidal login works fine again.
Now, I did not expect to clear the cache everytime I decide to switch off the NUC…
Please advise how to cure this - Thanks a lot in advance:grinning:
Kind regards

Hi @LucasM,

Can you verify that your RoonOS is up to date? You can do this by accessing the Web UI and choosing Reinstall under Operating System.

Hi @dylan
Operating system is updated and is now Version 1.0 (Build 174) - was Build 159…
After restart Tidal was logged in automatically, no actions needed…
Everything is fine - Thanks a lot again:)
Kind regards,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.