Tidal login not working [Resolved]

Just installed Roon on my MacBook Pro - it plays music from my local library fine, however it won’t play Tidal files. This is also the case with Audivarna. My tidal account seems in order, and i can play fine from the desktop app and via my squeezebox. Endpoint is Sonore Ultrarendu.

Any suggestions on how to resolve would be much appreciated!


Sometimes signing out of Tidal then signing in again plus a reboot cures that sort of thing

Thanks - tried that but no joy I’m afraid…

5 posts were split to a new topic: Playback issue - Local and TIDAL content

I had an issue with Tidal too, about 48 hours ago. Roon kept stalling on any and all Tidal tracks. Eventually I logged in to the Tidal app on my phone and it was very sluggish and some tracks wouldn’t start; that lasted for about 15 minutes. Then it started working for no apparent reason, and when I went back to Roon it was working there too. Overall it was glitching for maybe two hours.

@DILUK_DIAS and @Brian_Breneman — Thank you for the reports and feedback both are very appreciated! @Tim_Rhodes, thank you as well for chiming in and sharing your insight.

If you are still experiencing this behavior with TIDAL I would recommend trying the following (in this order) if you have not already:

  1. Try power cycling the device hosting your Roon core

  2. Try deleting your TIDAL cache.

If either of those tips do not yield a positive result:

  1. With the application not running … would you mind going into the database on your Core and deleting this file:


If you are unable to locate the ‘tidal_account’ file:

  1. Confirm that your TIDAL account is still active, as suggested here.


Thanks Eric. Gave all those a go, and still no joy.

Tidal account is definitely active as I can use the Tidal desktop app and via LMS fine.

I have reached out to Tidal support too.

Hoping i can get this working before my Roon free trial period ends so I can fully evaluate Roon!

I set up a new Tidal account (new email address and billing info, using the Audivarna trial voucher) and still no joy.

Which makes me think it’s an issue with my MacBookPro or my network…

So I installed Roon on my wife’s MacBook air and Tidal played fine! So it looks like it’s an issue with my MBP, that seems to affect Tidal on BOTH Audivarna and Roon. Anything you can do to help me resolve would be much appreciated, I don’t really want to reinstall the system on my work MBP if I can help it!



I resolved the issue. My DNS settings were out. Sorry for the false alarm and thanks everyone for your help. Now to enjoy the full Moon experience…

Same issue here. Login works from PC and iPhone - but get error on bad username/password with Tidal.

Hi @Ed_Schneider — Thank you for chiming in here and sharing your feedback with us!

Moving forward, since noticing this behavior have you tried any of the troubleshooting exercises mentioned in my previous post?


2 posts were merged into an existing topic: Playback issue - Local and TIDAL content

I can’t seem to login to me Tidal account - it doesn’t accept my password. The account works on tidal website. Any suggestions?

Deleting the cache worked for me! Thanks

1 Like

Hi @GHaz ----- Thank you for chiming in here, sorry to hear of the troubles. Confirming I have seen your PM as well, the feedback is appreciated!

Moving forward, can you please verify for me if you have given any of the troubleshooting advice from above a shot yet.


Tried a few that I Can understand, some are more complex. I’ve also gone back to Tidal. They are very poor and their system seems to be flawed!!

Hi @GHaz ---- I just saw you PM response and wanted to touch base with you.

Just to be sure we are on the same page, currently you are unable to login into TIDAL inside of Roon, correct? Furthermore, can you let me know what troubleshooting you have tried thus far based on the suggestions made in my earlier post.


Hi Eric
Yes, can’t login into Tidal and tried all the basic solutions suggested on Roon web. I’ve gone back to Tidal as they re-set my password and I now can’t access my Tidal account fully. No reply from them to date. Their system and service is poor - not sure why you went into partnership with them. My Tidal account is 3 months trial, I probably won’t continue with them unless they improve.

Thanks for the follow up @GHaz, letting you know that I have sent you a PM with some further troubleshooting steps.