Tidal login problem in Roon after reset of the Roon server

Intel NUC i7, Linux, Roon version 1.7 build 710
wired network from NUC to Lumin U1

No problem with network or audio, my own library works fine

Cannot login anymore to Tidal after I had to restart the NUC because it was very slow in finding anything on Tidal. Tidal on my Lumin or computer via their app works perfectly so it is not a password issue.
When try to log in I a new page opens in my browser, there I can login successfully and the back to Roon it keeps asking for login. Like a loop you enter. Tried on different devices but same problem.
I have no direct access to my NUC since it is headless. How to fix this without having to connect my NUC to screen/keyboard etc.

Thanks in advance,

Matthijs

What browser and the platform OS for the Roon Remote are you using?

Try these:

  • Reboot NUC
  • Clear browser cookies before you login

Tried the reboot, cleared cookies in Safari and same thing happens.
Tried on iPad, same problem.
Then on osx made Firefox my default browser and tried again after reset NUC, same problem.

Then I tried to make a new account on Qobuz and then I get this message in Roon:

Network connection error, see screenshot.

So it looks like Roon cannot reach the internet outside my house but does work inside on my home network, very strange.

Any tips? I cannot think of anything, my internet connection is fine, only Roon does not work and nothing has changed in my network setup.
Schermafbeelding 2021-01-22 om 13.34.39

Best regards,

Matthijs van de Vathorst

Set router DNS to 8.8.8.8

Make sure NUC gets DHCP ip address from router

Disable router firewall temporarily

Then reboot NUC

Thanks for the help. The problem is solved but i still do not understand fully how. Somehow the NUC has during reset switched ON the wifi while also being hardwired. Once i switched off wifi on the NUC everything worked again.

Sorry i bothered you with this.

Best regards,

Matthijs

1 Like

I understand switching on WiFi will impact wired network connection (this is normal because it screws up the routing), but this should not be happening if you’re using a recent generation of NUC running Roon ROCK, because ROCK does not support on-board WiFi for the recent generations.

What generation / model of NUC and what OS (ROCK or Windows) are you running for the Roon Core?

Hi,

The NUC is several years old now, bought it pretty soon after i bought Roon.
Rock did not exist yet so it was installed on Ubuntu linux.

But maybe i should reinstall Roon Rock on the NUC? Would it be more responsive?

Thanks in advance,

Matthijs

I see. If you have no problem now, I don’t recommend you change it.

The key to responsiveness is SSD, in case you are not using one in the Roon Core.

If you decide to install ROCK, I need to know what generation of NUC you have, and whether you have one SSD for ROCK OS plus one another drive for music inside the NUC. 5th generation cannot boot NVMe when you use ROCK. Earlier generations do not work.

Hi @M_v.d_Vathorst,

Having both network interfaces active can cause issues, thanks for letting us know that disabling WiFi resolved the issue.

I would make sure your NUC meets the ROCK guidelines before trying to install ROCK on it: