Tidal login unexpected error, please check your account details

Core Machine (Operating system/System info/Roon build number)

i5 3rd gen/Ubuntu Server 17.10/Roon 1.7 (Build 511)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus RT-AC68U, Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Directstream DAC, PI2AES, Oppo UDP-205

Description Of Issue

Intermittent Tidal login failure. Been having this issue for about a month, on and off.

Initially was fixed with a reboot.

I have been getting a few different messages, the latest one is:
“There was an unexpected error, please check your account details. (UnexpectedError)”.

I then logged into Tidal via browser and a different device and have confirmed that my subscription/login details are correct.

Then I searched the Roon community and tried the following steps.

I stopped the service and deleted the cache files located here:

I tried the stop-start-stop-start service to no avail.

I then tried deleting my Tidal account, but couldn’t find the file tidal_account in:

The only file here was:
tidal_storage_sync_version_string of numbers

Deleting that file had no effect.

Just wondering what I should try next?



Hi Dave,

Reboot your Roon core. That might help.

Cheers, Greg

Thanks Greg for the quick reply.

Unfortunately that doesn’t fix it. It did initially a couple of times, but now it doesn’t.


Hi @David_Huntington,

Can you confirm that you have an active TIDAL subscription? We’ve seen issues like this occur in the past when there was an account problem and the subscription lapsed. Even though you can log in via the TIDAL app, the subscription there may have an issue. You can check your TIDAL account settings to verify.

Hi Dylan,

Yes, the subscription is active. Double-checked with Tidal and they confirmed this.



Still having issues and was wondering why these files had reappeared in:

devicedb-prod.zip httpcache_2.db qobuz_1.db smc.db
devicedb-prod.zip.etag httpcache.db sessions tidal_2.db

I deleted all as root, but files have reappeared. Or does these files get created normally at reboot or when you login, as I don’t have a qobuz account either?

Hi @David_Huntington,

Yes, those files are regenerated once Roon starts up if they’re deleted.

Around the time this started occurring were there any changes to your setup?

In the past we’ve seen Google DNS help with similar TIDAL issues – Can you give it a try and let us know if it helps?

Hi Dylan,

Google DNS fixed this.

Thanks mate.

Happy New Year,


PS: No changes aside from updating Roon to latest version and adding another endpoint.

Hi @David_Huntington,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.