Tidal media and media file are loading slowly

Core Machine (Operating system/System info/Roon build number)

Win10Pro (v.1909, build 18262.1256) / Microsoft Surface Pro i7-7660U 2.5GHz, 8 Gb / Roon Core: v. 1.7 (build 710) stable (64bit)
WiFi connected

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS RT-AC66U wifi to EA-N66 repeater + switch D-Link DES-1008A in listening room

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi 4 Model B Rev 1.2 OC Linux 5.4.81-2-SPCKFSH-v7l+ w/ RoPieeeXL 3.020 connected by lan to EA-N66.
USB output -> iFi Zen DAC -> amp

Description Of Issue

Roon is reporting “Tidal media is loading slowly” or “Media file is loading slowly” depending if I play from tidal or NAS: track plays from 2-3 sec to 2-3 minutes and skip to next.

“System Output” plays fine.

Pi4 Device Setup by Default.

DSP disabled.

I browsed recent thread and try almost everything described but without any improvements:

  • TIDAL cache clear
  • MQA Capabilities: Render only (default) No MQA Support, Decoder & Rendering, Decoder only
  • DSD Playback Strategy: Native (default), Convert to PCM, DSD over PCM v1.0 (DoP), Initial dCS method

I try my own experiments but without success too:

  • Pi4 with DigiOne USbridge to Topping E30 DAC (no MQA)
  • Pi4 by WiFi
  • Pi4 by Ethernet connection to NAS and internet (lan from ASUS RT-AC66U router to D-Link DES-1008A switch)

Try connecting the core via ethernet. It is not as used to have the core server connected wirelessly.

Hi @Konstantin_Neznamov,

As suggested above and in our Networking Guide, we recommend using an Ethernet connection whenever possible for your Core machine. We also recommend against using WiFi repeaters as they tend to not be very reliable.

If you connect via Ethernet do you see better results?

I was having a song cutting off throughout Qobuz only and getting the loading slowing prompt, After several attempts to troubleshoot the problem, a modem reset worked to resolve the problem. I’ve been listening for about 30 mins with no errors. Hope this helps.


Thank you, guys!
I try cable connection and skip repeater: internet ethernet -> ASUS RT-AC66U -> ethernet -> D-Link DES-1008A switch.
D-Link DES-1008A cable connection to NAS, to Pi4 to Core.
Much better but not perfect: Tidal plays longer as 5-20 minutes but drops and skips to next song unpredictably. NAS plays fine, so far I watched it 1 hour or about.
Is it the best?
I’m not sure what I will be allowed to leave cables on floor in apartment and I have to switch back to wireless after experiments. Is there any recommended network gear or network parameters to avoid cables?
And one more thing. My iFi Zen Dac’ led indicates purple in case of MQA. I play with “MQA Capabilities” in Device Setup and have purple in case of “Renderer” only. As my thoughts “Decoder and Renderer” mode would do more job on Pi4 and save network load, isn’t it? But why doesn’t it give MQA to DAC?
Is this the way to optimize settings for wireless too?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.