TIDAL Media is loading slowly dropout



Hi @support, I’m new to Roon and enjoying so far but I have an error that appears when I play MQA tracks.

image.png960x268 15 KB

I managed to screenshot it: TIDAL: TIDAL media is loading slowly. This may indicate a networking or connectivity problem.

I only have 5 downloaded albums and they all play fine. Normal Tidal runs well (I have a HIFI subscription)

I have tried: logging out of Tidal and reconnecting/deleting the Roon cache/restarting my core/restarting the modem/router/speed checking…

I am running a 2013 MacBook Pro 8GB (Latest Mojave) RAM TG797N v3 Router to a Black Dragonfly USB DAC connected to my MacBook. It’s a pretty simple setup. I moved from Audirvana + that worked well but don’t want to go back but playing music smoothly is the big point.

I am hoping you can help with this.


Hello @Justin_Burnham,

Thanks for contacting us regarding this issue. Can you please let me know how your Core is connected to the network in this case? Is it over WiFi or Ethernet? Can you please try connecting it via Ethernet if it is connected via WiFi and let me know if the same issue still occurs? Does this issue happen for all of your endpoints or just one?


Thank you Noris,

Yes my MacBook Pro 2013 is the core and core is connected by wifi to my modem router. It makes a huge difference if i connect to my mobile as a personal hotspot (4G) Do I need to change something in my modem/router?

My MacBook is my only enpoint at this stage. I connect a Dragonly Black DAC with OPPO PM3 headphones. Pretty simple setup for me.

Thanks for your help,


@Justin_Burnham - Thank you for providing that information. We have seen users have a better TIDAL experience in the past if they change their Router’s DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?


I have been able to log into my router and changed the DNS to (Google DNS) this does not seem to change the error I am still getting after some time. It is really sporadic.
Tested connection with Ethernet cable and wifi switched off and still got the error.
Is it possible my ADSL2+ internet will just not run Roon? Tidal by itself runs fine…

Here is a screenshot of my signal path. Is there something I can change here?

Here is a screenshot of when the error happens. It seems that the Signal path folds or closes down as you can see.

Hoping you can help not sure where to go from here…


Does this only happen with MQA tracks? Other TIDAL content plays fine?

Can you explain this a bit more? Does this content stream properly if you connect via the hotspot?

In any event, I’m sure our Support team will be able to get this working for you. Since your setup is reasonably mobile, it might be interesting to know if you have the same issue on a different Wifi network, especially one running on a consumer router – I don’t like to push people to upgrade their routers without ruling out other possibilities first, but we’ve seen lots of issues resolved by using consumer routers, as opposed to those provided by ISPs, which tend to be a bit more locked down, and get updates less regularly. (More networking recommendations here).

Thanks for your patience here @Justin_Burnham!

1 Like


I have recently bought a Chord Poly and I have had the same issues you have. My conclusion is the following: if there is too little network bandwidth, Roon will show Tidal issues and the playback goes wrong this does not need to be the internet bandwidth loading the tracks it can also be the connection to the networked DAC. In your case I do think the wifi would cause slow loading because your DAC is directly connected.

I have an Asus router, an expensive one at that and what was happening was that on the statuspage it showed all of my wifi connections failing intermittently. This was never something that bothered me while browsing but with the audio it was an issue. The poly went missing from Roon sometimes and then came back.

Once I swapped to another wifi solution, I still have issues when upsampling too far but the Poly no longer goes missing from roon. But the message is still that Tidal loads slowly. Which is not really possible as the Mac Mini is connected using 1gbps ethernet to the router with 400mbps internet and on a 1 gbps connection to the access point. Before I owned the Poly the DAC was connected via USB to the mini which was on the same ethernet connection and I could upsample to 700+ khz. So I do think the wifi is the problem.

I changed my wifi and it now works ok as long as I do not use too much bandwidth (upsample too far, which in my case appears to be beyond 172 khz.

Hope this helps to narrow down your issues.

1 Like

Thanks Mike, I appreciate it, this really has me baffled.

I have continued testing this and to answer your questions. This seems to happen with processing MQA tracks. For example, I hooked up my Oppo HA-2 DAC (not a MQA unfolding DAC) and there are no problems with playback. I also tested Zone to Apple TV (not MQA) and this worked well too.
see screenshot for setup:

This seems to point toward some issue between Roon and my directly plugged in USB Black Dragonfly DAC.

Or something in translation over my devices is having hiccups that Roon can’t process.

Regarding Question 2 there. I initially thought that my mobile hotspot had no problems but it seems to have the same issues with streaming as well just much less frequently.

I have read into some wifi routers and have purchased a Netgear D7000 anyway as we were due for an upgrade. I really want to make Roon work.

Further testing and I have discovered I have less frequent (1 in every 5 tracks so far) dropouts if I switch off the Exclusive Mode Control…

Edit: so after this, I have just spent a great 2 hours of MQA exploration direct through Tidal on Macbook through Dragon Fly DAC into Oppo PM-3 Headphones with not one hiccup at all… #support

Edit2: New Netgear Nighthawk modem/router arrived this morning and set up was easy. Tested Roon and same issues with dropouts:( #support

Still standing by for any assistance.

Thank you so much for helping out, I really appreciate it.

Your comments above all have convinced me to try another updated modem/router. I will keep hacking at this and let you know what I find.

Thanks again,


A post was split to a new topic: Plabyack issues - MQA related?

A post was split to a new topic: Inconsistent Tidal Hiccups