TIDAL media is loading slowly - dropouts

System: Windows 10 Pro/Intel Core i7-6950x CPU @ 3ghz (10 core), 64 gb ram, 64 bit operating system, x64 based processor/Roon 1.7 (build 528) stable (64 bit)

Network: NBN connection box CM9200B/ Sagemcom F@ ST 3864V3 HP Modem/Ethernet

Audio Interface: RME HDSPe MADI FX/PCIe

Over the last two weeks I’ve been getting consistent TIDAL dropouts, but, they’re getting worse. I can barely get through half a song without it dropping out and skipping to the next song. Downloaded music plays fine. I have no issues playing through the TIDAL app, and, it appears our internet speed is normal (10ms ping, 50Mbps download, 20Mbps upload). I have the same issue if I’m using the ‘System Output’, or, one of the specific outputs from my audio interface. I’ve been using Roon for over a year now and never had a problem until now. I’ve read a few other posts with this issue, but, can see the advice is different for everybody, so, thought I’d post here with my specifications.



https://www.dropbox.com/s/ijwfezb5nk1qz5h/Adam_Casey%2C%20thetruevineproductions%40gmail.com.zip?dl=0 (I’ve attached my logs here, which I can see you usually request when you reply)

Hi,Adam you seem to have exactly the same problem as me,and it also looks as though you’re in Australia ,like me. Have been using Roon with Tidal for about 6mnths,all working beautifully until a couple of weeks ago,at which time problems exactly the same as yours began. NBN speeds identical,streaming my collection from hdd is perfect,Tidal through the app is fine,just Tidal within Roon ,no matter what output ,has become an issue.Keen to see what results from your post to support,cheers,Mark.

1 Like

Hi Mark, Yep: I’m in Melbourne. I can see a lot of people are having the same issue. I’m guessing it’s a bug in the new 1.7 build.

I’ve just checked and can see I’ve been using Roon since February 2018 and Tidal since September 2018, without an issue. It has always been so rock solid; I really hope this problem is a small hiccup.

Hey Adam,Melbourne as well.Think it was about August last year I joined,and as with you,everything absolutely rock solid until just recently.Just going with the number of posts with similar problems,surely it’s to do with 1.7 build.Way too many coincidences.I suppose you’ve just got to hope for transparency with this,and if there is something wrong,that we’ll be provided with honest answers.I can fully appreciate that support issues can be highly complex due to the many,many different configurations out there.Here’s hoping we get it sorted soon,because I love using the software.

1 Like

Hi again Adam,just out of interest,have you tried any different DNS settings?I changed mine last night and performance seems better (at the moment!!).I’ll wait and see if it holds up.

1 Like

I haven’t tried this; let me know how you go.

Sure.Will do.

1 Like

Hi @Adam_Casey,

Thanks for reaching out and I really appreciate you providing all of the useful info in your post (including logs and System Output testing), this would have definitely been out starting point for troubleshooting so we saved a few steps of data gathering here :slight_smile:

Looking at your logs, I am seeing the following when you try to play TIDAL content:

03/31 14:52:51 Trace: [System Output] [HighQuality, 16/44 TIDAL FLAC => 24/48] [100% buf] [PLAYING @ 1:10/15:37] Grey & Green - Félicia Atkinson
03/31 14:52:51 Trace: [streamingmediafile] immediate read of http://sp-pr-ak.audio.tidal.com/mediatracks/CAEaKRInMDA4ZWVjY2E0YjRiMmU1NDk3ZGM0ZDk2ZjVmNTI3MzJfNjEubXA0/0.flac at 6815744 length=76660678
03/31 14:52:56 Trace: [System Output] [HighQuality, 16/44 TIDAL FLAC => 24/48] [72% buf] [PLAYING @ 1:15/15:37] Grey & Green - Félicia Atkinson
03/31 14:52:59 Info: [stats] 3917mb Virtual, 2251mb Physical, 1031mb Managed, 2181 Handles, 113 Threads
03/31 14:53:01 Trace: [System Output] [HighQuality, 16/44 TIDAL FLAC => 24/48] [32% buf] [PLAYING @ 1:20/15:37] Grey & Green - Félicia Atkinson
03/31 14:53:05 Debug: [prebuffer] sleeping in read -- this isn't good
03/31 14:53:06 Trace: [System Output] [HighQuality, 16/44 TIDAL FLAC => 24/48] [2% buf] [PLAYING @ 1:25/15:37] Grey & Green - Félicia Atkinson
03/31 14:53:06 Debug: [prebuffer] sleeping in read -- this isn't good
03/31 14:53:07 Debug: [prebuffer] sleeping in read -- this isn't good
03/31 14:53:09 Debug: [prebuffer] sleeping in read -- this isn't good
03/31 14:53:11 Trace: [System Output] [HighQuality, 16/44 TIDAL FLAC => 24/48] [2% buf] [PLAYING @ 1:30/15:37] Grey & Green - Félicia Atkinson
03/31 14:53:11 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":3214}
03/31 14:53:11 Debug: [prebuffer] sleeping in read -- this isn't good
03/31 14:53:11 Trace: [System Output] [zoneplayer/raat] sync System Output: realtime=91056587000 rtt=0us offset=-59771413us delta=18us drift=-33436us in 91.06s (-367.186ppm, -1321.871ms/hr)
03/31 14:53:12 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":7214}
03/31 14:53:12 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":24000}
03/31 14:53:13 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":24000}
03/31 14:53:13 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":24480}
03/31 14:53:14 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":24000}
03/31 14:53:14 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":24000}
03/31 14:53:14 Debug: [prebuffer] sleeping in read -- this isn't good
03/31 14:53:14 Info: [stats] 3917mb Virtual, 2251mb Physical, 1030mb Managed, 2180 Handles, 113 Threads
03/31 14:53:15 Trace: [System Output] [raatclient] GOT [7] {"status":"Dropout","samples":24000}
03/31 14:53:15 Warn: [System Output] [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
03/31 14:53:15 Trace: [System Output] [zoneplayer/raat] too many dropouts. stopping stream
03/31 14:53:15 Info: [System Output] [zoneplayer] advance didn't change the track. returning short read
03/31 14:53:15 Warn: Track Stopped Due to Slow Media

As you may have noticed, the buffer is rapidly accelerating towards 0%, which is not good. This could indicate a few things: either the network connection is dropping, or the requests are not going through fast enough, or there’s an issue with your Core’s HDD/RAM and reading/writing data is not occurring fast enough.

As @Mark_Apperly suggested, my first thought here would be to change your DNS servers to Cloudflare / Quad9 / Google DNS and see if that’ll help. You should also try temporarily disabling DSP to eliminate this as a potential variable (while testing).

Do let me know how the DNS test goes and if the issues are still the same, just let me know and we can take another look, thanks!

Thanks, @noris. I’ve now changed the DNS servers and, thus far, the playback issue seems to be rectified. Fingers crossed it stays that way: I’ll keep listening throughout the day and see how I go. Many thanks for your help (and you too, @Mark_Apperly). :+1:

1 Like

Hi again,

So, after changing the DNS servers and playing loads of music for the past 4.5 hours, while the playback is much improved, I’m still getting dropouts. I’ve had about 6-7 this morning. I’m not sure what aspects of the DSP you want me to play with. Is there a way to stop all DSP processing in the settings?

If this is what you mean (above), I never had any DSP settings on anyway.

I also have the same problem and I’m located on the other side of Earth so it doesn’t seem to be a Melbourne problem. It’s one of many Roon/Tidal problems I experience since a month or so.

I hope it’s solved soon since the possibility to listening to music at home is essential these days.

//Magnus, Stockholm, Sweden

1 Like

Hey Adam,Tidal seems to be holding up for me since the dns change (though I really don’t want to speak too soon!). I’ve got tomorrow off so I’ll give it a good run then. Hopefully something is going to work for you,Mark.

1 Like

Hello @Adam_Casey,

It doesn’t look like you have any DSP active, it may have just been the automatic conversion to the System Output’s native sample/bit rate.

Can you please note the exact local time + date + track you experience this issue on and send me a new set of logs? I wonder if the error has changed since upgrading the DNS server or if you’re still getting buffering issues.

Hi Noris,

The issue is terrible today; just a moment ago I couldn’t get through 10 seconds of audio. Went to the Tidal app, and, voila, it worked fine. I am not getting any other connectivity issues; they’re all relating to Roon. I’ve been playing pretty consistently between 10am-8pm AEST. Yesterday I didn’t play as much. I’ll post the logs in a new reply.



Hey Mark, how is your playback holding up?