TIDAL media is loading slowly error

Tidal is dropping on every song after a few seconds. Do others see this tonight?

It’s takimg 20+ seconds for song to start then it starts then drops.

Attached is screenshot with same error I was having last night.

Who owns this problem?

Local music from NAS is fine.

Internet connection is 26 mbits.

Thanks for your report, @Paula_Dickerson. I’ve moved your post into it’s own thread so we can better assist you.

May I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

  • Since noticing this behavior have you tried rebooting your Core machine and networking hardware?
  • Are you able to play TIDAL tracks from the Core machine outside of Roon?
  • Does this behavior happen for all endpoints, or just the microRendu?

Thanks!
Dylan

1 Like

Dylan,

My local library operates fine. It’s tidal that is slow. I suspect my AT&T internet connection. Google speed test reports 7 MBit sometimes.

When it’s around that speed Roon will start playing after 10-15 seconds then stop after 5-10 seconds then either start playing again fine the rest for the song or skip the track and try the next one. Very consistent behavior.

Sounds like buffering. But I would expect Roon to do a better job buffering the stream and take care to buffer enough and not just drop the track.

If I run Speedtest it will tell me 24Mbit. While google says 8. Still see,s like enough regardless to stream music.

Thanks

Thanks for the update, @Paula_Dickerson!

It may be a slow internet connection, but there are a couple of other things we can look into as well.

Can you confirm whether or not the TIDAL app exhibits similar behavior from the same Core machine?

Can you also give me some information about your networking setup, including all hardware in use?

In the past we have seen Google DNS help with similar reports. Can you try using Google DNS and let us know if you notice a change?

Thanks,
Dylan

Dylan,

I can’t change the dns setting on my att router. After the first song in album loads after a few tries sometimes the rest of album plays, why doesn’t Roon have a configurable timeout setting to account for this problem?

Hey @Paula_Dickerson,

As we mention in our networking guide, we typically recommend against using ISP provided networking hardware. ISP-provided routers are often underpowered and poorly behaved, and we’ve seen them cause issues in the past. Additionally, using a different router would allow you to change your DNS settings.

It’s hard to say whether the issues you’re experiencing are related to this for certain, but we do like to give people a “heads up” when ISP hardware is in use, since it can impact the product in a number of ways, and you may encounter some limitations going forward.

In general, Roon is a bit more aggressive when it comes to buffering than the TIDAL app, so while your network may be able to handle that, Roon is a bit more demanding and your network may be struggling because of that. We are investigating possibly making changes to how we buffer content in the future.

One other thing I’d like to recommend is trying to use a VPN and see if there are any improvements in TIDAL performance. I’ve seen this help TIDAL performance in another case with a similar ATT setup, so it may be worth a try.

Thanks,
Dylan

Thanks Dylan. Removing isp routers seems to be asking for support trouble. I am also Ethernet wired no wireless in the picture except iPad oc.